Apologies for the long question. I will keep it as simple as I can.

Last week my Macbook Pro (13-inch, Mid 2010) started to act strange.

It started when I tried to open Skype and received an error complaining that the program could not start because Skype could not read (or lock, unfortunately I can't remember) it's skype.plist file.

I restarted my Macbook hoping that would fix the problem (and I hadn't restarted in a while so I figured it was overdue).

My Macbook restarted and played the startup chime but then hung at the grey startup screen with the spinning wheel. I thought nothing of it and did a hard shutdown but no matter how many times I did, the Macbook never advanced past the grey startup screen.

I tried to boot using Safe and Verbose mode and got the following error in both cases:

BootCacheControl : Unable to open /var/db/BootCache.playlist: 22 invalid argument

I googled the error and tried various solutions with no luck.

The Macbook would boot to the built-in Mountain Lion recovery partition.

At this point I decided to backup my data so I could mess with the hard drive a bit more without fear of losing any data. I booted in to the recovery partition and cloned my hard drive onto another using a USB enclosure. It seemed to work OK and I verified all of my files were on the backup hard drive by plugging it into another Macbook.

After cloning my hard drive I verified and repaired the disk and disk permissions using the disk utility in the recovery partition but that had no effect.

At this point I decided to reinstall Mountain Lion. I tried numerous times to reinstall it with the hard drive inside the Macbook (both using the recovery partition and a bootable Mountain Lion SD card) but couldn't get it to install. Eventually I got it to install, but only when the hard drive was placed in a USB enclosure. I knew this probably indicated a bigger underlying problem but decided to go ahead anyway.

I installed Mountain Lion successfully but now it will not boot with the hard drive connected inside the Macbook, only when it is used in my USB enclosure. When the hard drive is placed in my USB enclosure it boots to Mountain Lion without any problem.

With the hard drive inside the Macbook:

  • If the Macbook is booted as standard, it hangs on the grey startup screen with spinning wheel
  • If it is booted in verbose mode, it seems to boot successfully (shows no errors when the white text show up) and then hangs on a black screen with a solid white cursor in the top left corner (I can type at this point but it does nothing, it doesn't appear to be a terminal window)
  • If it is booted in safe mode, the progress bar appears, progresses to the end and then hangs on the grey startup screen with spinning wheel

I noticed a lot of suggestions on the internet to replace the hard drive cable to the motherboard. I did and it had no effect.

I've tried using another hard drive running a brand new install of Mountain Lion and that behaves exactly the same (boots fine using a USB enclosure but doesn't boot when connected internally).

I've booked an appointment at the Apple store but figured it was worth posting the question anyway, in case anybody has a similar issue in the future (hopefully I'll be able to post the answer, if nobody else does, after a visit to the Genius bar).

Any suggestions?

Thanks for reading.

  • Was your MBP under warranty or did Apple charge you to diagnose and/or replace the cable? May 27, 2017 at 15:47
  • I think you've done all the troubleshooting you can. Seems like a logic board problem.
    – Hefewe1zen
    May 27, 2017 at 17:55

4 Answers 4

  1. You have eliminated the possibility of a hardware issue on the hard drive by installing a new hard drive and also by installing the operating system on the previous hard drive via USB.

  2. You have replaced the cable connecting the internal hard drive to the mother board, so it's not a cable problem.

  3. The only thing left seems to be the hard drive controller on the motherboard. I expect the Genius bar will recommend replacing the motherboard. For an older model Mac like yours, it might be worth searching for a replacement motherboard and having a local Mac repair shop swapping it in for you. It might cost less.

  • I thought (but hoped not) that was the case. Thanks for taking time to read the question.
    – Lewis
    Aug 20, 2013 at 19:56

I took my Macbook to the Apple store. After performing some tests the man at the genius bar agreed with me that it would either be the cable or the motherboard. He said he would replace the cable again (just to make sure the one I installed wasn't defective or installed incorrectly) and if that didn't work, replace the motherboard.

I just received a call saying the Macbook was working after installing a new cable. I guess the cable I installed was defective or installed incorrectly.

I hope no-one ever has a similar problem, but if they do, this is what fixed it for me.


I literally unscrewed the cable, rubbed off some dirt and grit and dust, replaced it and SOLVED my issue! Thank you to this vlogger for his video! :) try it before you reinstall, format, or buy a new cable! Vid below: https://www.youtube.com/watch?v=Amg5w0rlwDo


This YouTube video was incredibly helpful, and worked for me:


I'd only add that as I chose to upgrade my HDD to SSD at the same time as fixing this problem using James' technique, I had to re-set the PRAM by starting-up while holding the CMD-OPT-P-R keys down. Before I did that, the MacBook would boot from the drive connected to USB, but not while installed directly onto the HDD SATA cable. Once the PRAM was re-set, all works properly (and I'm not even sure I need a new cable).

  • 1
    Welcome to Ask Different! Please describe the essential suggestions of the video that helped you solve the problem. Link only answers do not age very well. We don't know if the video will be there in the future. Thanks! Jun 5, 2017 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .