1

I tried setting up a Ruby on Rails project on my nice safe volume called "Data RAID". The set up failed with some strange errors that I eventually tracked down to the space in the path name. It works if I execute it on another volume. I tried setting up a symlink to the directory, which works fine with the cd command, but doesn't help with the set up. Is it possible to get an application to use a symlink or other method that avoids the pathname with a space?

The Terminal command I'm running that errors out is

rails new projectnamae

One other twist is something I set up to specify the location of the gems:

mkdir ~/.bundle
touch ~/.bundle/config
echo 'BUNDLE_PATH: vendor/bundle' >> ~/.bundle/config

It is with the gems that I'm getting the error.

  • @tubedogg, thanks for suggesting the changes. I rejected them because they didn't look right in the change panel. In the end, I think I made all the same changes on my own. – curt Aug 20 '13 at 2:42
  • I was kind of confused about that, yes. :) – tubedogg Aug 20 '13 at 2:43

You must log in to answer this question.

Browse other questions tagged .