16

I am in the process of moving several VMs created in VMWare Fusion 5 into ESXi 5.1, which I just installed on a Mac Mini Server. I am able to connect just fine via the Windows application installed on another VM. I have created two OVF files, one for Server 2003 and another for Server 2012. Both files were created without incident. I am able to upload them to the ESXi server seemingly without issue as well.

However, when I start either of the VMs, I get the following error(s):

Console:

enter image description here

And in the GUI:

enter image description here

I'm unsure how to proceed, as I have followed the steps outlined to create an OVF file and upload it to the ESX. Both of these VMs work fine through Fusion.

Thanks in advance.

  • 1
    Just guessing, but it looks like there's a problem with the virtual hard disk; maybe it's not connected as expected. I'd check there first. – zigg Aug 20 '13 at 0:19
  • @zigg, I've redone the VM conversion several times. Each time, I reload it, and get the same error. – Dave Aug 20 '13 at 0:20
14

After arduous research and trial and error, I've finally been able to solve this issue. First of all, if you're migrating Fusion VMs to ESXi, I recommend not using the OVF tool. At least for me, it never worked properly. Instead, I used the vmware-vdiskmanager tool, which is built into Fusion. The instructions for this migration are listed below:

  1. Open Terminal.
  2. Run the following command, inserting the correct VMWare Fusion vmdk file source and new vmdk destination:

    /Applications/VMware\ Fusion.app/Contents/Library/vmware-vdiskmanager > -r /path/to/vmware_fusion.vmwarevm/vmware_fusion.vmdk -t 4 /path/to/esxi.vmdk

  3. The conversion process, once complete, will create two files: filename.vmdk, and filename-flat.vmdk.
  4. Launch the vSphere client through your web browser to your ESXi server.
  5. Once logged in, go to File | New | Virtual Machine
  6. In the Configuration window, select Custom.
  7. In the Storage window, select the datastore location to store the new VM.
  8. In the Virtual Machine Version window, use the default option of Virtual Machine Version: 8.
  9. Select the desired settings for Guest OS, CPUs, Memory, Network, and SCSI Controller.
  10. In the Select a Disk window, choose the Do Not Create Disk option.
  11. Click the Finish button.
  12. In the ESXi server settings, select the Configuration tab then click on Storage.
  13. In Storage, select your datastore and right-click to select Browse Datastore.
  14. Select the folder name that corresponds to the new VM.
  15. Select the Upload button.
  16. Upload the filename.vmdk and filename-flat.vmdk files from Step 3.
  17. Once complete, you will only see the filename.vmdk file in the datastore.
  18. Select the VM and Edit virtual machine settings under the Get Started tab.
  19. Click the Add button in the Virtual Machine Properties window.
  20. For Device Type, select Hard Disk, and choose Use an existing virtual disk.
  21. Locate the datastore and select the existing disk.
  22. In the Advanced Options, leave the default settings.
  23. Select Finish and OK to close the Virtual Machine Properties.
  24. At this point, you should be able to boot to the newly migrated VM.

Guidance for this came from MacTech's June 2013 issue, reproduced at the author's blog here. Many kudos to Rich Trouton for this article.

1

I would suggest using the VMWare converter to move the virtual machines from one host to another. This will do all the heavy lifting for you. It's free.

http://www.vmware.com/products/converter/

This is your best option as the converter does all the vm configurations and settings for you. This is also suggested in the KB Article (1000936) from VMWare.

You have to do this on a windows machine. Inside a VM on the same fusion host works just fine.

  • 1
    I've been unable to find a Mac version of the VMWare Converter, so I'll give this a whirl once I stand up a non-production Windows machine for the operation. – Dave Aug 20 '13 at 0:19
  • 1
    Ok, I just run it inside a win7 vm. Sorry I forgot to mention that. – Digitalchild Aug 20 '13 at 6:46
  • The conversion process worked, or did so apparently. However, when I upload the files via the ESXi interface, they load to the file system, but they give me the same error as above. I'm missing something somewhere. – Dave Aug 21 '13 at 1:50
  • You should have been able to convert and install the vm directly to the esxi server without needing to copy any files. – Digitalchild Aug 21 '13 at 5:10
  • 1
    If it is a VM that originated from a product other than Fusion, the process works fine. It's the conversion of Fusion VMs that is giving me the issue. – Dave Aug 21 '13 at 12:41
1

There has been an update to OVFTOOL around since March 2015 (Now V4.1.0.). With this OSX version I have much fewer trouble to get OVFTool to work. Even a OSX VM transfer from Fusion to ESXi is now just a one line like:

/Applications/VMware\ OVF\ Tool/ovftool --compress=9 ./OS_X_10.vmx vi://root@ESX6i

Finally it is working like expected, when the old versions just copied parts or I had to try 10 times to get the desired results with some crude workarounds. So please give it another try! ;)

  • excellent! I'll have to give that a try. – Dave Mar 29 '15 at 18:06
  • Did you manage to get this working to do what you wanted @Dave? As although your answer above does work, I'm also trying alternative solutions – Rekovni Oct 10 '17 at 11:05
  • Yes, I did. I'd be interested in your alternate solutions as well. – Dave Dec 11 '17 at 20:03

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.