2

I recently had tried to make some hidden desktop icons on my desktop following the instructions found here. I am on Mac OS X Mountain Lion. I ended up somehow making every file a hidden file. The files are all visible but are just transparent and I cannot open some of them.

How do I make all of these files become unhidden files so they are no longer transparent and I can access them better?

6
  • 2
    What exactly did you do to hide them?
    – nohillside
    Commented Aug 19, 2013 at 19:09
  • I followed this tutorial. I am not sure what went wrong. osxdaily.com/2009/09/23/hide-all-desktop-icons-in-mac-os-x
    – MAS02
    Commented Aug 19, 2013 at 19:50
  • 1
    Have you tried undoing what you did? If you ran that first command in the link, have you tried running TRUE instead of FALSE like in the link? Commented Aug 19, 2013 at 20:34
  • +1 to the above comment. "defaults write com.apple.finder CreateDesktop -bool true" will remediate your issue.
    – Dave
    Commented Aug 19, 2013 at 20:35
  • Yes I have tried that, but for some reason all of the icons are still transparent and being shown as hidden files.
    – MAS02
    Commented Aug 19, 2013 at 21:42

3 Answers 3

1

You might have accidentally show the hidden files in Finder. Try this command to hide all the hidden files:

defaults write com.apple.finder AppleShowAllFiles -bool NO

To show it again, change the BOOL value from NO to YES:

defaults write com.apple.finder AppleShowAllFiles -bool YES
0

To unhide all icons on the desktop, simply open the terminal then run:

defaults write com.apple.finder CreateDesktop true

Then restart Finder with the following command (also in the terminal):

killall Finder

The reverse is true if you'd like to reverse this and hide icons on your desktop:

defaults write com.apple.finder CreateDesktop true
killall Finder

Here's a video showing the effect this will have.

0

Download a program called Clean Slate (free trial). Once you download the free trial choose the option to remove desktop icons then uncheck the option, that's how I fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .