4

When I'm connected to my company's VPN, some websites won't load. For example, both imgur and tumblr will just hang trying to connect:

$ curl -v http://imgur.com
* About to connect() to imgur.com port 80 (#0)
*   Trying 23.23.110.81...
* connected
* Connected to imgur.com (23.23.110.81) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0 OpenSSL/0.9.8x zlib/1.2.5
> Host: imgur.com
> Accept: */*
>

Other sites, like twitter and the AWS console will load eventually but without any CSS applied (some pages will load properly though).

The VPN uses PPP and so pretty much all of my traffic shows up in Wireshark as PPP Compressed Datagrams. ppp.log doesn`t show anything but connect/disconnect info.

I had been using this exact same setup for a month or two without any issues. It was in the last week or two that I noticed this issue. Running iOS 10.8.4.

Any idea on how to debug this?

  • 1
    Are you sure your company doesn't have any type of filtering software in place, specifically that was installed recently? – tubedogg Aug 19 '13 at 2:21
  • @tubedogg. I don't believe so. These sites load fine when I'm directly connected to the network, and the IT guy has no idea why this is happening. – Dean Aug 19 '13 at 2:28
5

Talked to a coworker who had the same problem. The issue was that the mtu was set too high on the ppp0 interface.

$ ifconfig ppp0
ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1396
        inet 192.168.0.207 --> 192.168.0.200 netmask 0xffffff00

I changed it from 1396 to 1250 and it now works fine. To make the change permanent, I did the following:

$ sudo <your_text_editor_of_choice> /etc/ppp/ip-up

#!/bin/sh
/sbin/ifconfig ppp0 mtu 1250

$ sudo chmod 755 /etc/ppp/ip-up

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .