10

I have Windows 7 installed on a 15-inch Retina MacBook Pro.

According to Apple's Boot Camp Installation and Setup Guide, pg. 10...

Select an operating system during startup

You can select which operating system to use during startup by holding down the Option key.

This displays icons for all available startup disks and lets you override the default setting for the startup disk that is in Startup Disk preferences (OS X) or the Boot Camp control panel (Windows), without changing that setting.

1 Restart your Mac and hold down the Option key until disk icons appear onscreen.

2 Select the startup disk with the operating system you want to use, then click the arrow beneath the icon.

I'm finding that holding down the option key has no effect -- the machine boots into whichever OS was last running.

This is true whether I'm starting from the shut-down condition, or restarting.

I've tried hold down each of the two option keys and I've tried holding down both at once.

I've tried pressing the keys from before the startup chime and just after.

The only way I've been able to control which OS starts up is to restart from the Boot Camp control panel in OS X in either OS.

Any thoughts on how to get the machine to behave as described in the docs?

  • 1
    Just clarifying: you're trying to press Option on a stock macbook's keyboard or a wireless keyboard? – 000 Aug 18 '13 at 18:06
  • On the laptop's own built-in keyboard. – Agvorth Aug 18 '13 at 18:09
  • Also try to reproduce the bug with a USB keyboard connected to the Macbook; as a last resort, you can install a third-party boot manager rEFInd, it will show up on its own without need to press Option – 000 Aug 18 '13 at 18:09
  • As stated here, if on a Wireless keyboard, press Alt when you hear the chime. Before that, keyboard is not detected. support.apple.com/kb/PH11132?viewlocale=en_US – AbiusX Jun 25 '14 at 6:06
  • Boot sequence is prime espionage target. Must be simple, transparent. Booted software takes control over machine. Any unexpected behavior here suspect. Option key must always go straight to menu. – user98843 Nov 2 '14 at 20:34

13 Answers 13

10

I had a similar issue and the below trick solved it.

Resetting NVRAM

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R.
  3. Turn on your Mac.
  4. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound.
  5. Hold these keys until the computer restarts and you hear the startup sound for a second time.
  6. Release the keys.

Source: https://support.apple.com/kb/ht204063

  • I did it using an external usb keyboard ! – konus Apr 20 '16 at 12:57
  • I found that my D-Link USB-2 hub was causing the problem, so I removed it. – Pierre Thibault Aug 19 at 19:56
3

There are 2 methods if the Option key doesn't work.

METHOD 1 @Amol mentioned it, his answer is perfectly correct. On your Mac, go to:

System Preferences > Startup Disk

Now click the Operating System that you want your next start to boot into.

Truly simple.

METHOD 2

Download rEFIt and install it. Then reboot.

You might need to reboot twice or more before the rEFIt menu starts showing up on boot.

Good luck :)

2

Two things to try:

  1. Hold Option before pressing the power button and don't release it until you see the Boot Menu.

  2. If that doesn't work, try resetting your Macbook Pro SMC as explained here.

2

Just go to System Preferences in Mac and choose Startup Disk. It will give you choice of Windows or Mac as want for your next start up of your computer.

1

Through experimentation, I found that disconnecting the Apple extended keyboard from an unpowered USB bus and reconnecting it directly to a USB port on the back of my Apple Cinema Display fixed this problem. Apparently the firmware that's necessary to choose which partition to boot from won't act on holding down the Option key otherwise.

0

I've had similar issues : while I was holding the key, the system would do as if if didn't recognize the keyboard(I'm on a iMac, with Bluetooth connection between the computer and the keyboard). On the contrary, with a usb port keyboard, it worked anytime ! (but that wasn't practical to plug another keyboard)

I understood that you have to be sure that the Bluetooth connects. So this is how to do it :

  • while the computer is off, let's make sure that the keyboard is also off (for example, by pressing its own power button)
  • Now let's put the keyboard on : if the keyboard was off, it will search for a new connection - the green light of the keyboard must blink
  • Then you can turn on the computer and follow the clear instructions from above ("resetting NVRAM"). I suggest that you hold the option key (ALT) directly after having push the computer start button , so that the Bluetooth connects directly.

That works everytime.

0

I just had the same problem on osx 10.11, I have used refind before and thought that installing it might help, as it turns out it did and it works fine, the main difference between refit and refind is that by default refit installs to the os x root partition but refind install s th the hidden EFI partition meaning that it shouldn't just stop working randomly like refit has for me in the past.

0

I'm using a wireless keyboard / mouse (if it matters).

I found that I had to plug my dongle into a certain usb port, or these startup keys would not be received by the computer (even though I could use any of the ports post boot).

I also seemed to have better luck based on the timing of when I pressed the key(s). Doing it as soon as I heard the chime worked more reliably then holding it down before the chime even went off. I can't confirm that 100%, but it's worth a try if you're banging your head against the wall!

0

i found my issue was the wireless keyboard, it wasn't connecting with the boot so computer would not respond to the option key. I first made sure the keyboard was on/active then booted the computer.

0

I had the same problem that option key was not working. The reason for this is that I was having another wireless keyboard USB attached to Mac. Once I removed, it started working.

0

I had this very same problem on my older MacBook laptop running bootcamp to dual boot both Snow Leopard and Windows 7 and I couldn’t get to Windows 7. To make it worse I can’t login to OS X either cause I haven’t used it for so long cause Windows runs great on a Mac that I forgot all my passwords. The only way I got it to work was to remove the hard drive and after a few tries booting the laptop I was able to boot from Snow Leopard DVD and went into startup disk and set to boot from Snow Leopard DVD and restarted and powered it off and put my hard drive back in and from there was able to go back into startup and set to boot into BootCamp and am able to boot into Windows with no issues. I still have issues with alt key but I just use Boot Camp Control Panel to select which one I want to boot and ok with that work around.

0

I have an older Mac and I had the same issue. Zapping the pram did the trick BUT I had to be aggressive and hold down the key combo for more than two cycles of start up tone. In other words doing it the recommended two times did not work. Out of frustration I held it down for four times the startup tone. While swearing I might add. Suddenly the EFI boot option appeared. I guess the pram can really get corrupted. Or the swearing worked🤠

  • 1
    Swearing works. Also threats of replacement by a cheap Windows machine. – IconDaemon Jun 29 '18 at 19:40
0

Try removing all hardware from your computer before startup!

I had the same problem and I found out it was an error with my mouse, because my mouse (Razer Naga 2012) was interfering with the keyboard for some reason.

Hope this helps!

You must log in to answer this question.

protected by Tetsujin Aug 21 at 15:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .