5

Drives and dmg's are mounting okay on my Mac, and I can find them at /Volumes/. However, they aren't appearing in the sidebar in the Finder. What's the best way to start fixing this?

  • Have you hidden the devices list? Mouse to DEVICES in the sidebar and to the right of it it will make visible "Show" or "Hide" Click on that to revert – user151019 Aug 18 '13 at 13:47
  • Okay, I'm officially an idiot. The device list was hidden. Thanks :) – Jim Aug 18 '13 at 13:50
5

In Finder you can show or hide the disks and other devices

Go to the sidebar and mouse over DEVICES you get to the right text that says Show or Hide. Click on that word to toggle the display of the devices.

  • Holy damn! I was browsing for solutions, looking for problems, removing plist configs, restarting, tweaking preferences and I could find that goddamn hidden "show" link... THANK YOU!!! – Alex Kaushovik Mar 12 '14 at 19:53
2

I faced a similar problem today, but the "devices" show/hide solution didn't quite solve it for me.

However, going to the Finder's Preferences > Sidebar > Devices, the box next to "External disks" was neither empty (unselected) nor check-marked (selected), but rather marked with a hyphen (partially selected). After clicking the box next to "External disks" until the check-mark appeared, my mounted image started to show up in Finder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .