When I try to update my iPad from my Win 7 desktop, I get this error message which says Could not start session with iPad and then the iPad disconnects.

Even during normal syncing I have noticed that my iPad disconnects a few seconds after doing the backup. It's for this reason that I have never been able to do a full sync of my iPad.

Note that the same usb cable/port works just fine for syncing/updating my iPhone 4.

I even tried reinstalling my Apple USB drivers as mentioned here but to no avail.

2 Answers 2


Several things to try:

  1. Soft reset your iPad by holding the power button and home button at the same time for a few seconds. The iPad will reboot. You won't lose your files so don't worry. When it completely boots up, try the sync again.
  2. If the problem persists, then you may try to use iTunes to restore the OS. Be cautious when using this method because you may lose data. Maybe you should try syncing on another PC/Mac computer before you do this restore:

Connect your iPad to your Windows 7 (cancel sync if you know it won't go through), then click your iPad in the "device" list; Press the restore button and follow the prompts.

  • rebooting ipad does solve the error msg problem, but i still get the continuos disconnect issue.
    – pdeva
    Mar 10, 2011 at 14:14

Last time I had a similar error the connector in my iPhone was blocked by a small "stone".

I could see that the plug was no longer fitting "perfectly".

After I cleaned it with a small piece of plastic it worked perfectly again.

Befor you continue searching for software errors - can you confirm that your connector fits fine and is clean?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .