11

Strangely, Command + Click has stopped opening links in new tabs on my computer. It opens them in the same tab, as if I hadn't pressed Command. This problem occurs with Chrome, Firefox, and Safari. My home Mac doesn't have this problem, and my coworker's Mac doesn't have this problem.

My Command keys work just fine with other hotkeys like Command + O to open files.

I tried disabling extensions, didn't help.

Anyone else experience this?

System:

$ specs chrome os
Specs:

specs 0.4
https://github.com/mcandre/specs#readme

/Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --version 2>&1 | grep -v Unsure
28.0.1500.95 

system_profiler SPSoftwareDataType | grep 'System Version'
System Version: OS X 10.8.4 (12E55)
  • Do you updated Chrome recently? Which extensions do you have installed? Does Cmd + Click work in Safari and Firefox? – Ricardo Sanchez-Saez Aug 16 '13 at 13:56
  • 1
    Maybe you need this – sameetandpotatoes Aug 16 '13 at 13:57
  • Command works just fine with hotkeys like Command + O to open files. Command + Click is not working in Firefox or Safari either. Yes, I tried that extension, it didn't help. This problem occurs on all websites and bookmarks, not just certain websites. – apennebaker Aug 16 '13 at 14:12
  • Ah, my Apple Bluetooth keyboard was interfering from my backpack. Problem solved. – apennebaker Aug 16 '13 at 14:30
  • 1
    Help us keeping this place organized. Make your findings (the keyboard from a backpack) as a answer, so others can find it. – Ruskes Aug 17 '13 at 20:57
2

As @apennebaker commented. The issue ended up being a bluetooth keyboard in a backpack.

Ah, "the old" backpack and keyboard problem.

Obviously not everything is better with bluetooth.


Please check your bluetooth and make sure that is not the cause of your problems when troubleshooting keyboard issues.

2

While many people might have another keyboard hooked up to their computer, that wasn't the case for me. You can be sure by disabling bluetooth (if your main keyboard is wired).

Other problems I've researched include: specific websites mess with CMD+Click via javascript either intentionally or accidentally. To debug, try a few different websites. If it's just one website that you really want CMD+Click to work on, there are some chrome extensions you can try, I haven't used any of them.

Make sure your CMD key works correctly. The OP in this thread did this via using CMD+0 or CMD+1 to navigate to different tabs.

Not sure what my issue was, but restarting the OS fixed it. Give that a try. Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .