9

This has really baffled me:

While my internet connection works, I can't access specific websites with Safari (or any other browser for that matter). I don't get a 404 page; Just an error message that Safari (or Chrome or Firefox) can't access the server at some.location.com.

For example, I can't access www.apple.com or www.reddit.com while some other sites I can access come out "broken" (e.g. in imgur or Facebook I get no images, I can't login etc.) I can ping them, nslookup works, traceroute fails. Other websites seem to have no problem at all (e.g. youtube, this one etc.). It also works ok for the guest account, but not for mine.

Things I've tried so far

  • clearing the browsers' cache
  • flushing the DNS cache
  • adding/removing Google DNS servers
  • restarting the laptop and the wireless router
  • disabling the firewall
  • checking the content of /etc/hosts(which only contains localhost entries)
  • checked for user restrictions (which are not set)
  • killing/restarting mDNSResponder

and I still have no idea why this weird behavior started so suddenly. I'm not using any proxies like Little Snitch, and a quick search for malware came up clean.

  • 2
    I took the liberty of removing all answers because they weren't actually solving the problem but rather providing ideas and hints on where to look further leading to extended discussions in the comments. Question has been edited to include findings, please use question comments to ask for further details. – nohillside Aug 13 '13 at 18:30
  • 2
    Follow-up questions from the comments which still need answering: Can you run traceroute for some sites which don't work? Can you create a new user account and see if the problem persists there? As it happens all of sudden, what did you change in the system on that day? – nohillside Aug 13 '13 at 18:32
  • 1
    traceroute fails ("No route to host"). I traveled back home and the it persists in my home network but it is not as intense as before (i.e. some of the websites, like Facebook, seem to work ok, others still nothing). The problem does not persist in other user accounts.I didn't change anything on the system that day. I did not apply any updates, install/remove software, or change any settings prior to this problem appearing. I run an update after it appeared, but to no avail. I have no other network-related software running(e.g.utorrent, proxies,firewalls). I don't even know where to look next. – phileris Aug 16 '13 at 16:31
  • So, the issue affects only your user account on the MBAir, and only on your home network? On other networks using your account - the issue is gone - and at home other devices work fine? – Scot Aug 16 '13 at 17:24
  • 1
    Found it! It was PeerGuardian working on the background which started all those problems and mostly blocked https connections. I had installed it ages ago, then disabled its launch on startup and forgot its existence but kept it installed. Apparently, it kept running regardless, but showed up in the terminal (ps aux | grep PeerGuardian). I don't know why it would start blocking https/ssl suddenly and on its own though, maybe an update? I killed it (terminal: kill KILL followed by PID) and unistalled it (with AppCleaner). Everything went back to normal again! – phileris Aug 16 '13 at 18:16
4

For such problem one more option is there where you can check your DNS settings. To fix that problem, open the Network pane of System Preferences and select your network connection in the list on the left. Click Advanced followed by DNS.

In the DNS Servers field, you should see one or more IP addresses. If those addresses are enabled (black, as opposed to gray), select each one in turn and click the minus-sign (-) button. Then, regardless of whether there are already addresses there in gray, click the plus-sign (+) button and enter 208.67.222.220; repeat with 208.67.222.222.

Some more Ipv4 and Ipv6 addresses are given at computerknow.org, you may see there.

2

I'm in the same boat. I've tried deleting cache and cookies, but it did't work for me. After surfing some websites, I found some tips that worked for me.

  • Go to System Preferences,choose network
  • Click "advanced", go to the "Hardware" tab, and click on "configure", choose "manually"
  • Click on mtu, change it to "custom" and set the mtu number to 1453 (I dont why but the number is something like a networking secret from ancient times)
0

I had the sam problem (www.apple.com, www.facebokok.com etc did not load). Disabling of IPv6 in network settings helped me. After that Facebook is loading without problems.

0

Here's a solution that helped me - I was desperate as nothing I had done had helped, the problem was only specific to my macbook (other devices connected just fine) and across browsers.

After speaking with three different assistants from Apple Support, the third of which stayed with me on shared screen for over an hour trying to help me resolve this, I bumped into a solution on my own, so I'm sharing it here in case it helps other people:

First back-up (just in case) and then delete the following folder:

/Library/Preferences/SystemConfiguration

Then, reboot (and the system will re-create the folder with default settings.)

You will have to enter your network's credentials again (password etc).

It worked for me.

Before that I couldn't access certain google services (youtube, docs, drive) although others worked fine (google.com, gmail.) After this, I could access everything just like normal.

The weirdest thing was that, I don't remember doing anything in particular that caused this to happen yesterday (when the problems started) so I have no idea what exactly went wrong - all I know was that deleting all the configuration files sorted it out.

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .