6

A little background

I wanted to create a Mountain Lion recovery USB because I currently only have a Lion recovery USB. While downloading the installer image from the Mac App store, the computer froze and I had to perform a hard shutdown.

My question

I cannot boot into OSX anymore. How can I get it working again? I will try anything.

What I have tried

  • Entering Safe mode by holding shift on startup. But this does not seem to work. No matter how I do it.
  • Using the Lion recovery USB. This does not work either - I can only see a grey circle with a slash. Maybe this is happening because I have Mountain Lion installed. As I have said above, I do not have a Mountain lion recovery USB.
  • Contacting Apple Care / Genius bar because this Macbook Air has Apple Care. They will not help, because the Macbook Air's warranty is no longer valid as my Mac suffered from water damage not too long ago.
  • Downloading Mountain Lion from another Mac which only runs Lion. This is not possible in this case: The Mac App Store will only "offer" to download Mountain Lion - but when I click it the download is blocked because the Mac only runs Lion and cannot update to Mountain Lion (the Mac is too old). I should be able to download Lion at least, but have not found any option.
  • Oh, yeah. Sorry. I meant safe mode. – gentmatt Aug 11 '13 at 10:32
  • Sounds like a RIP is on order. – Ruskes Aug 11 '13 at 18:30
  • @Buscar웃 I got it working again! Internet recovery was the ultimate solution even though getting there was not as easy as one would expect from Apple. – gentmatt Aug 11 '13 at 19:42
9

PRAM Reset

On boot, hold ⌘ cmd + ⌥ alt + P + R until the second boot chime. This can fix a variety of things including problems due to recent kernel panics.

Recovery HD

On boot, hold ⌘ cmd + R to boot into the Recovery HD. If this fails, hold ⌥ alt on boot, and select Recovery from the options available.

From here, you can open Disk Utility and select Repair Disk.

Target Disk Mode

If you wish to get information from the computer, and you have another computer and some way of connecting the two, you can boot into Target Disk Mode by holding T on boot. Files can then be taken off the drive by the other computer as if it was a normal external drive.

Internet Recovery

If you have a recent backup or Target Disk Mode worked (and your Mac is post-July 2011) you can start fresh by using Internet Recovery.

Hold ⌘ cmd + ⌥ alt + R on boot to begin. A new copy of OS X will be downloaded from the internet and installed, erasing your internal drive.

enter image description here

  • Internet Recovery mode just downloads an image of the recovery system from Apple's servers. You can use Disk Utility or perform a clean reinstall or an upgrade install normally after that. There was also a firmware update that added support for Internet Recovery mode for some mid-2010 to mid-2011 Macs. – Lri Aug 11 '13 at 13:17
1

This is a reply to @grgarside's post. Because the answer is so long, I'm posting it as another answer:

  1. A PRAM reset did not change anything except for the bringing back the loud choo choo sound. :/
  2. I don't have a recovery partition anymore - it must have disappeared when I was changing the partition table using Disk Utility.
  3. This requires a FW 400 to TB cable which I do not have.
  4. This caused lots of unexpected, unintuitive troubles...

    1. Even though I have a German keyboard layout, the keyboard layout was for some reason changed to US English. Try figuring that out if you don't see the characters you type because they appear as dots only.
    2. My wifi is WPA2 only and Internet recovery can't communicate with that standard. Therefore I had to change the wireless protocol to WPA/WPA2.
    3. Even though I have purchased Mountain Lion with the my Apple ID, the internet recovery only offered to download Lion. When choosing Lion, I got this error: "The install data could not be written to the Volume. Contact AppleCare." enter image description here
    4. So, I had to recover from my Time Machine backup. "That's the better option anyway," you may think. No, it's not - because I won't get the recovery partition. If you want a recovery partition, you need to first install a fresh copy of OS X and then use the migration assistant to recover your data from the Time Machine backup.

So, I went ahead and started to recover my Time Machine Backup after partitioning the disk. Somewhere in the middle the backup aborted with the message: "During recovery an error occurred. Restart the computer and retry the recovery."

enter image description here

After entering Internet Recovery for a second time, the internal SSD is not shown anymore (in Disk Utility or using 'diskutil list'). Even an Ubuntu live USB will not see it, as if the EFI decided to hide it...


Update:
After another attempt to enter internet recovery, the SSD appeared again and I managed to fully recovery my 10.8.4 Time Machine Backup!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .