When I download a .dmg file it somehow ends up on my desktop automatically. Even after I install the .dmg, it is still on my desktop.

How do I stop these from appearing on my desktop? Should they be there?

  • Are you talking about the downloaded .dmg file or about the volume you see after you double-click a .dmg?
    – nohillside
    Aug 11 '13 at 7:24

If you mean volumes that are shown after you mount dmg files, you can uncheck this checkbox:

You can eject volumes from Finder's sidebar or by selecting their icons and pressing ⌘E.

  • That makes more sense. Probably more likely what he was asking but looks like we covered both possibilities! Aug 11 '13 at 13:17

Depends on which browser you're using but you likely have safari settings configured to save all downloads to desktop. You can change this behavior in the preferences menu and have it save everything to downloads or simply ask you where you want to save.

As for the .dmg files, after installing, you want to "eject" the dmg file by going into finder, left sidebar, scroll down, and clicking the eject icon next to the dmg file you see mounted there. Then you can simply trash the dmg file or move it to another folder if you want to keep it.


I was having issues with Sequel Pro.

  1. Click the dmg file.
  2. You will see a folder open.
  3. This folder shows the icon for the app.
  4. Drag that to the applications folder.

You can open your app from the Applications folder now.

You can delete your dmg file or keep it, up to you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .