0

My document in Pages 4.2 for Mac has custom paragraph styles for a couple of levels of headings. I'd like to get a bird's eye view of my document that shows only those headings, not the paragraphs in between.

I can set whether each paragraph style is included or excluded in the table of contents (TOC), but I don't want to insert a Table of Contents into the document; I want to view this in a sheet, menu, separate window, or something else that is part of the application rather than the document.

I can switch to the outline view, but that shows everything, including regular paragraphs and list items. If I can get the outline to exclude those (or restrict to the headings), that would work.

1

I believe you need to use the Levels control. In the screenshot below, my Body text (regular paragraphs) aren't shown, because I've asked the outline mode to show only heading levels 1 and 2.

Levels control in Pages 4.3

(I'm using Pages 4.3 but hopefully this is the same in your 4.2?)

  • I have that control, but if I set it to anything other than “All”, the outline is empty. (Probably relevant: All of the paragraph styles in use in the document are custom; none are any of Pages's built-in styles.) – Peter Hosey Aug 9 '13 at 23:56
  • Ah! I think the only way to solve this then is to modify your document to use the built-in styles (I don't see how to tell it that a custom style is a level 3 heading, for example). Hopefully this is simple: select your "custom heading 1" style in the Styles drawer, choose "Select All Uses of custom heading 1" from the menu, then change the selected text to the built-in Heading 1. (Also reformat the built-in Heading 1 to match your custom style, but you see what I mean?) – Ashley Aug 10 '13 at 0:08
  • Unfortunately, using Pages's built-in styles isn't an option. I need to send this document to a publisher that requires me to send them a Word document that uses their custom styles. (My document is born from the template Word document they send to authors.) – Peter Hosey Aug 10 '13 at 5:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .