3

When I plugin a usb-drive or open dmg-archives they don't appear under the 'Devices' section in the sidebar of the Finder anymore.

The drives are there when I check with 'Disk Utility', they appear on the Desktop and I can browse the files if I go to /Volumes.

I have 'Hard disks' and 'External disks' checked in the Finder preferences -> Sidebar tab.

Any ideas on how to get them to show up in the sidebar?

I'm using MacOS Lion 10.7.5.

  • In your Finder sidebar, can you see your internal hard drive listed under Devices? If you hover over Devices you should see either Show or Hide just to the right of it, perhaps it's set to hidden? – Mr Rabbit Aug 8 '13 at 12:56
  • You are right! :) How embarasing. I never saw the "hide/show" when I hovered over 'Devices' before. Thank you. Write your comment as an answer and I'll accept it. – Jörgen Lundberg Aug 8 '13 at 20:57
  • No worries, I only know because I set "Shared" to be hidden automatically since the majority of my users rarely use it. I'll get about 2 calls a week though asking where the networked Macs are and have to explain that Shared is set to hidden. – Mr Rabbit Aug 9 '13 at 13:13
4

In your Finder sidebar, can you see your internal hard drive listed under Devices? If you hover over Devices you should see either Show or Hide just to the right of it, perhaps it's set to hidden?

1

In my case it was a faulty usb drive. I still don't see the hard drive in "Finder" sidebar, but I'm figuring that's just the way it is with Lion? I adjusted the Finder Preferences so I can now see the HD and other drives on my desktop...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .