I'm getting constantly interrupted by the same error, "There was a problem connecting to the server "admin's MacBook". The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again."

The server in question is my older Macbook. A few days ago I needed to copy iSync from the old MB to my newer MBP so I established a bluetooth file sharing link. When I was done I turned file sharing off again and shutdown the old Macbook. Apparently my MBP (the newer one) is still constantly trying to contact the old MB. How can I get it to forget that that machine was ever connected?

Here's the error dialog:

enter image description here

So far I tried following:

System Preferences Network

Deleted BT connections

Then Open the Sharing and Disable Sharing

Restart MBP

without success.

It would appear that the problem is related to having installed iSync under Mountain Lion. Here is a copy of the console log at the moment that the error dialog pops up:

8/7/13 11:36:43.623 AM iSync[18691]: ApplePersistence=NO
8/7/13 11:37:13.632 AM iSync[18691]: [0x10010ba70] |Server|Warning| failed to connect to the server: NSPortTimeoutException connection timeout: did not receive reply
8/7/13 11:37:13.909 AM NetAuthAgent[18695]: ApplePersistence=NO
8/7/13 11:37:15.984 AM SyncServer[18693]: [0x7fd9d340bea0] |DataManager|Warning| Client com.apple.iSyncDU.IMEI356495004217990 image file path /Volumes/Applications/iSync.app/Contents/PlugIns/ApplePhoneConduit.syncdevice/Contents/PlugIns/PhoneModelsSync.phoneplugin/Contents/Resources/MOTV535.tiff does not exist.
8/7/13 11:37:43.786 AM iSync[18691]: [0x10010ba70] |Server|Warning| failed to connect to the server: NSPortTimeoutException connection timeout: did not receive reply
8/7/13 11:37:49.170 AM SyncServer[18693]: [0x7fd9d340bea0] |DataManager|Warning| Client com.apple.iSyncDU.IMEI356495004217990 sync alert tool path /Volumes/Applications/iSync.app/Contents/MacOS/sync-tool does not exist.
8/7/13 11:38:13.939 AM iSync[18691]: [0x10010ba70] |Server|Warning| failed to connect to the server: NSPortTimeoutException connection timeout: did not receive reply
8/7/13 11:38:21.018 AM SyncServer[18693]: [0x7fd9d340bea0] |DataManager|Warning| Client com.apple.iSyncDU.IMEI356495004217990 formatter bundle path /Volumes/Applications/iSync.app/Contents/PlugIns/ApplePhoneConduit.syncdevice/Contents/Resources/Formatter.bundle does not exist.

Now I suspect that because I simply copied over iSync, it's still configured for the other machine, which it cannot find.

Simply deleting iSync did not do the job. launchd must still be configured to run whatever backup daemon got installed when I ran iSync.

  • You do not have to wait till than, publish a link to any of the photo hosting websites or your choice.
    – Ruskes
    Commented Aug 7, 2013 at 7:47
  • Have you looked in your user or system launch agent folders for the agent. If there is one removing it and restarting may fix the issue.
    – markhunte
    Commented Feb 11, 2014 at 11:25

3 Answers 3


This error typically comes up when OSX is trying to access a file or folder on a remote server, but it cannot connect to that server.

I have two examples to give an idea of where this can come from:

  1. You are able to have MacOS (or OSX as it was known at the time) connect to a remote folder automatically at login. Typically these are shown in the "Login Items" tab of the "Users & Groups" pref pane

    Example of an automatically-connected Folder on an AFP server

  2. When an application attempts to open a file that's on a remote server, OSX automatically tries to connect to that server in order to access the file.

    For example: If the music in your iTunes library is on a mounted network drive, and you have not connected the drive yet, playing a track will delay while it connects the drive before iTunes will play the track.

In both cases, if the server where these files are located cannot be found, that error will come up.

Since the computers are no longer connected (in this case over Bluetooth), the server cannot be found.

  • 2
    Spot on @joshfindit. Your #1 response was causing the same, annoying issue on my Mavericks. I clicked the "-" button on "Unknown" entries and rebooted. Problem solved. Thanks man.
    – MannyC
    Commented Oct 7, 2014 at 6:10
  • 1
    Perfect solution. Should be accepted answer, although I suppose it can't be marked as such since the question is considered a duplicate.
    – shiri
    Commented Aug 3, 2019 at 2:20
  • 2
    This might solve it in some cases. In many situations you may want your computer to silently connect to network locations when they are available (and ignore otherwise), and you don't want to remove them from the list. The system throwing this connection error at the user every other minute is a real nuisance.
    – user169684
    Commented Nov 27, 2019 at 15:11
  • @jerry I personally agree, but that's something that needs to be raised with Apple
    – joshfindit
    Commented Nov 28, 2019 at 14:16
  • Maybe. There was/is a little hope that, since it is a Unix-type system, this kind of behavior would not be baked into a binary.
    – user169684
    Commented Nov 28, 2019 at 22:54

In case the message appeares even on the user login screen before even being logged in try to remove the AppleFileServer preference file and the OpenDirectory folder. Run the following commands in terminal to delete the files

    sudo rm /Library/Preferences/com.apple.AppleFileServer.plist
    sudo rm -r /Library/Preferences/OpenDirectory


On you MBP

Disable BT devices in BT menu

Than Go to: Home > Library > Preferences and locate the com.apple.bluetooth.plist and the com.apple.fileExchange.plist and send both to trash "don't delete yet"


  • Those are the first things I tried.
    – Keith
    Commented Aug 7, 2013 at 8:13
  • I could not know that since not mentioned in your question.
    – Ruskes
    Commented Aug 7, 2013 at 8:15
  • Did you restart MBP after making the changes?
    – Ruskes
    Commented Aug 7, 2013 at 8:18
  • 3
    BT has nothing to do with it. We're talking about SMB, CIFS, ... Commented Jun 5, 2016 at 6:00
  • 1
    I don't even have those files...
    – Ahmed Eid
    Commented Jul 24, 2018 at 3:30

Not the answer you're looking for? Browse other questions tagged .