I have an iPhone 3g running iOS 4.2.1 with no SIM card. I'm attempting to jailbreak it so I can use it, but it will not enter DFU mode, even though I have tried repeatedly. I am attempting to use redsn0w 0.9.15b3, but my mac should recognize an iPhone in DFU mode anyway, so the jailbreak's probably not the issue. The home button is connected to the board, I opened it up and checked.

Please do not just parrot the instructions from the redsn0w jailbreak, as I have already read them many times. I am looking for advice on what may be preventing the iPhone from entering DFU mode.


This may seem silly, but this is what I do when I have had to troubleshoot DFU mode (getting in and out of). First cross your fingers that it is software. Do you have a different USB cable that you can try with? Access to another computer to attempt with. I'm sure you have already tried rebooting both the iPhone and Mac, right? Not sure if you know or not, but you actually don't the computer nor the cable to get in DFU. You may want to try without plugging it in as well. The only difficult part with that is since it is not plugged in you will not know when it boots into DFU mode until you plug it in and the computer chimes. These seem basic but even the best of us forget about switching ports, rebooting the computer or trying another cable.

  • +1 For mentioning that you don't need the iPhone plugged in to enter DFU. – Andrew Larsson Aug 8 '13 at 15:30
  • Sorry for not getting back to you, I can easily get into DFU mode while not plugged in (thanks for the tip), but when I plug it in, it reboots normally. I've tried this on two different macs. – Muricula Aug 11 '13 at 20:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .