2

I just bought an old iMac (model identifier PowerMac6,1) running Mac OS X 10.2.8. Everything is working great except the internet connection. There is an Airport option for connecting to WiFi, so I'm assuming the iMac has the hardware/software capabilities required.

I can successfully connect to my AT&T U-verse WiFi (I select the network, put in my password, the Airport icon shows the signal strength, etc.) but I'm not connected to the internet. Every time I try to load a webpage, Safari alerts that the server can't be found. All my other devices are able to connect to my WiFi with no problems.

Is my iMac just too outdated to be able to fully connect to an AT&T U-verse WiFi connection? If not, how can I successfully connect?

UPDATE

Okay, when I go to System Preferences > Network on the old iMac, the TCP/IP tab is selected. Along with the following options:

Configure: Using DHCP
IP Address: xxx.xxx.xxx.xxx (self-assigned)
Subnet Mask: xxx.xxx.x.x
Router: --
DHCP Client ID (optional): --
AirPort ID: xx:xx:xx:xx:xx:xx
DNS Servers (optional): xxx.xxx.x.xxx
Search Domains (optional): gateway.2wire.net

UPDATE

Connection info: enter image description here

There were no devices in the MAC Filtering list

  • 1
    In a web browser can you get to 192.168.1.254 ? That's the configuration page for the router, if you can get to that there might some setting in the router preventing your iMac from sharing the Internet connection. – tubedogg Aug 6 '13 at 15:40
  • 1
    Is your wireless router a 5GHz model? It is likely that your 10.3 machine cannot access the 5GHz band. Your router should also have the ability to transmit on the 2.4 GHz band. It may also be labeled at 802.11b|g vs 802.11a|n you will need to activate the b|g channel – TheWellington Aug 7 '13 at 15:53
  • 1
    One simple suggestion, as it doesn't seem to have been mentioned so far: how about plug the iMac in via Ethernet? (This would give another useful piece of information for the troubleshooting, and perhaps it might be a workable long-term solution if wiring permits?) – Ashley Aug 9 '13 at 13:02
  • 1
    → hw731: don't search a minute about which WEP, WPA or WPA2 is using your MacOS X, it does only support WEP (it's a shame), and as long as your AirPort icon display black lines, your password was accepted. Your problem is purely DHCP centric. – dan Aug 9 '13 at 19:19
  • 1
    → hw731: you don't have a wireless interference problem, and you don't have a too weak SNR problem. – dan Aug 9 '13 at 19:20
2
+50

Ancient WLAN adaptors only support none or (insecure) WEP encryption methods. Current router come with WPA/WPA2 preconfigured. For those cases like yours, virtually any routers support manually selecting WEP encryption. Try this.

While it's better than no encryption, it's benefits are close to zero. So make sure not to transfer sensitive data via WLAN while it's encrypted using WEP.

  • WEP == lie! WEP isn't better than no security, it's worse. Exactly as an empty extinguisher is worse than no extinguisher at all. – dan Aug 9 '13 at 19:21
  • 2
    If you know the extinguisher is empty, you won't rely on it but you still can knock someone down with it. – Max Ried Aug 9 '13 at 20:46
  • Imagine you're a thief. What house would you break in? The one with the el cheapo Mickey Mouse gimmick style lock? Or into the house with the gaping wide open door? – Max Ried Aug 9 '13 at 20:48
  • → Max: fantastic allegory for WEP. The thief would target the Mickey lock: "They have something to protect, and they're really bad at it!". And he's well advised. Behind the open door is… ☺. – dan Aug 9 '13 at 21:52
3

If the iMac is indeed limited to WEP security, an alternative would be to use a 'wireless gaming adapter' such as this one. Originally marketed to Xbox 360 users who did not want to buy the official wireless adapter, these devices handle the wireless connection (using stronger WPA/WPA2 security) and provide an ethernet connection to the iMac.

1

Simpler network configuration

To analyse this typical network problem, one has to first define a simpler network configuration so as to focuse on the problem to fix. Here is how: Within:

System Preferences > Network

select:

Location: Edit Location… > +

enter the name of a fresh configuration:

AirPort @ home

select it, and click Done.

Select every network interface, but the AirPort one, in the left subwindow and delete it: AirPort @ home configuration 1

Your interface won't look as this screen capture made on a much recent MacOS X, but the idea remains. This was working on the first Mac OS X: remove the useless network interfaces to be sure you are testing the only one you want to trouble shoot.

Configure the remaining AirPort interface:

Network name: *your home network name*

and upon request enter your WEP password, select the bottom right Advanced… button and define the TCP/IP as static with the following values (which should be correct for your network): AirPort @ home configuration 2

Click Apply and confirm that the button on the left of the interface name (AirPort) switches to green within a few seconds.

Tests

Once this configuration is up, open a Terminal and type the following command:

ping 192.168.1.254

to see if you can directly reach your router.

If this ping is OK, then the problem is on your router.

Next chapter depends of this test result.

0

A machine running OS X 10.3 likely has an Airport card that cannot support modern WiFi connections in the 5GHz band, also known as 802.11n. You may be restricted to WiFi connections in the 2.4GHz band, also know as 802.11b or 802.11g

Your router should be able to support both bands simultaneously. You will need to look at your router's configuration and activate 802.11b|g while leaving the 5GHz band (802.11n) active for your more modern devices.

  • 1
    While this is a really good thought (and I'm jealous I didn't think of it lol), AT&T does not supply any U-Verse (2wire) gateways that support 802.11n. Therefore if he has WiFi coming from the gateway, it's already b or g. – tubedogg Aug 7 '13 at 16:25
  • I did some research and I think @KevinSchumacher is right. I don't think 2Wire routers support 802.11n anyway. Any other ideas? Still can't establish a connection. – hgwhittle Aug 7 '13 at 22:27
  • Do you have any settings on the gateway that would prevent a new device from connecting? Go to your gateway's configuration then Settings > LAN > Wireless and look down towards the bottom at MAC filtering. Actually while you're there, is Wireless Mode set on b/g or just one of them? – tubedogg Aug 7 '13 at 22:44
  • @KevinSchumacher - Edited question with more info. Thank you all for your persistence. – hgwhittle Aug 8 '13 at 2:26
  • Note: hw731 is running Mac OS X 10.2.8, not 10.3. – dan Aug 9 '13 at 16:21
0

While it is no help to the OP I am having similar problems on my modern Retina MacBookPro. Mac's used to be the envy of PC users in their effortless ability to glide from WiFi hotspot to WiFi hotspot, connecting seamlessly at each one, but increasingly I am failing to connect to third party signals, with similar symptoms.

Basically password is accepted, WiFi signal is strong, but there is no connection to the internet and I end up with a self assigned password, indicating a problem with DHCP handshaking.

Sometimes I can shake the tree by going into Network Preferences and clicking "Renew DHCP Lease" on the TCP/IP tab of the Advanced section of WiFi preferences. This forces the Mac to request a new IP address.

Occasionally I can make it work by entering a manual IP address if I already know the subnet of the router by looking on another computer.

However my point is this - I believe that of late Apple's TCP/IP stack and the WiFi implementation of third party vendors has started to diverge, perhaps over timeout periods, and I think the OP is having the same problem.

For $100 he could plug an Apple Airport Express into the U-verse and see if he can connect to that more cleanly?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .