6

I use MBP 13" early 2011 and tried to connect with external moniter ACER X163w but the monitor displays a "no signal" error.

I use official cable Display MiniDVI to VGA and run OS X 10.6.8.

Might the external monitor be too small or how else can I troubleshoot this?


[Update] I have tried on my bigger monitor 25". Still says no display. it seem the problem is with my current OSX. I searched in google, some people also have same problem.

  • Can you confirm that the external monitor that you tried works by connecting it to another computer? – sameetandpotatoes Aug 6 '13 at 13:10
  • @sameetandpotatoes Yes, i had confirm it. I normally use the monitor for my PC and it work well – GusDeCooL Aug 6 '13 at 13:34
  • 1
    And does the MiniDVI to VGA work with other displays? – Saaru Lindestøkke Aug 6 '13 at 13:53
  • @BartArondson I don't know yet. I will try tomorrow testing it with my Friend Monitor – GusDeCooL Aug 6 '13 at 14:10
6

Here are some troubleshooting steps that I would try:

Reset the System

Reset your Mac's parameter RAM and SMC

Try another Cable

Although you are using the official MiniDVI to VGA adapter, it is possible that it might be damaged, so I would try connecting your monitor with another official adapter.

Reset the Resolution

  1. Start up in Safe Mode (Power + Shift on startup)
  2. Apple Menu => System Preferences
  3. Choose Displays from the Views menu.
  4. Select another resolution and refresh rate.
  5. Restart.

Software Update

It is also possible that you need to update to Lion (Maybe even Mountain Lion if you want).

Other Links and Resources

Another Apple user who was using a Powerbook with the Acer x163W had issues too. That question was answered here and recommends a different monitor because of the Acer monitor's lower resolution than his Mac.

  • I already have the latest OSX version and firmware. But now i will try to reset with safe mode. Do you have any suggestion what refresh rate and resolution i should use? – GusDeCooL Aug 6 '13 at 14:11
  • A fairly low resolution because your monitor will not support a higher resolution than your Mac. – sameetandpotatoes Aug 6 '13 at 14:12
  • Already tried this. But still no result :( – GusDeCooL Aug 11 '13 at 18:31
  • GusDeCool, I never asked you this but in your Display Preferences in System Preferences, is the external monitor detected? – sameetandpotatoes Aug 11 '13 at 18:54
  • @sameetanpotatoes No, my mac not detected external monitor in system preferences. – GusDeCooL Aug 12 '13 at 16:07
1

I had the same problem and I used gfxCardStatus v2.3 to switch to Discrete only graphics card and now it works.

1

 -> System Preferences -> Display

Press Option -> "Detect Displays" on bottom right corner

If fails, try to tick "show mirroring options in the menu bar when available"
On AirPlay menu bar, try different option and see if second display responds.

0

I had the same problem and what worked for me was Resetting the System Management Controller (SMC). I did it couple of times.

0

Resetting NVRAM / PRAM did the trick for me (having mavericks).

0

Changing the resolution of the external monitor, in the system preferences, usually solves the problem for me. I can then switch back to the optimal one, and the image stays on. No restart is needed.

  • 2
    You can't change the resolution on a monitor you can't detect. – furtive Aug 8 '16 at 20:45
0

One thing to try- I was getting the 'No signal' message on my external monitor, and couldn't work out why it wouldn't connect, as I was using the correct cable and it has worked many times before.

After trying many things, I unplugged the cable from my laptop, turned it upside down, and plugged it in again. It worked! So, unlike a USB, this cable fits both ways, but only works if it's the correct way up. When it's the right way up, it has a little image of a rectangle on it. (This may differ depending on your cable.)

I know, super obvious, but I was puzzled for a bit.

0

I had a similar problem that I solved by passing the HDMI signal through a powered HDMI Splitter box from Matrix.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .