I ask because I configured and installed a profile for a network account on my Macbook Air (10.9) to create a synchronized Mobility Home on a Mac Mini server (10.8).

However, I cannot login as this user on the server or my Air, because I receive the message that the home already exists. This occurs even though I have removed the devices from profile manager and the user from the group.

I expect this is because I have not updated the configuration profile on the account, but I cannot do so because I cannot log in as that user.

So, I'd like to purge any instance of these configurations. So far, I've tried the following:

  1. Deleting /Library/Preferences/DirectoryService/
  2. Clearing the MCX Cache as per this Apple KB article

I am asking specifically how to clear these configs, but if it comes up, yes, I have deleted the home folder on the Air and the Mini, and no, neither have a local account with the same name.

  • Is it other users or one specific one? Can you delete and recreate the user? Commented Aug 6, 2013 at 22:04
  • The user did not show up in the user list in System Preferences or dscl, so I couldn't recreate it.
    – Tohuw
    Commented Aug 7, 2013 at 12:38

2 Answers 2


The profiles appear to be stored in


I'd not recommend tampering with it, though.

To see what profiles are installed, and then remove one, assuming you can sudo to the user, you could try:

root$ sudo -u chymb profiles -L
chymb[1] attribute: profileIdentifier: com.stackexchange.apple.test
There are 1 user configuration profiles installed for 'chymb'
root$ sudo -u chymb profiles -R -p com.stackexchange.apple.test
  • I ended up resolving it a different way (by fixing the problem that prevented the mobility home from being created), but this answers the question and is what I was looking for. Thanks!
    – Tohuw
    Commented Aug 7, 2013 at 12:39

If you haven't restricted System Preferences in the Profile Manager it should be an option in System Preferences > Profile.

Delete it from there and reboot.

  • I could not login as the user, so the profile did not appear there.
    – Tohuw
    Commented Aug 6, 2013 at 13:05
  • Sorry, missed that. Commented Aug 6, 2013 at 22:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .