0

I just got my iMac back from Apple---they had to replace the video card for me---and the internal mic is not working. In System Preferences -> Sound, I can select "Internal Microphone" or "Line In" and I get nothing on the volume bar for either when I speak. I moved the input volume slider all the way to right and I still get nothing, but oddly enough as I move the slider I register sound. Only while the slider is moving though.

I went to Utilities -> Audio MIDI Setup and made sure that the inputs were not muted. I also tried a few combinations of the "Format" options (44100.0 Hz and 96000.0 Hz each with 2ch-24bit, 2ch-20bit, and 2ch-16bit) but still no dice.

I went in to Garage Band -> Preferences -> Audio/MIDI and made sure that "Built-in Microphone" was selected under "Audio Input". Still no dice.

I tried restarting and pressing [command] + [option] + p + r until the third startup noise. I am not sure what this is supposed to do, but I found the suggestion on a forum somewhere. No dice.

Does anybody have any suggestions for what else I might try to get this working, or how I might find out for certain if the mic is broken? If my mic is broken, does anybody know of a good video or article detailing how to replace it on your own?

I would not be terribly surprised if Apple broke my mic during the repair since they made several other errors and I had to bring the computer back to them twice before the original problem was fixed.

EDIT: I plugged in an external mic that I own and the computer seems to be receiving sound through that. Any suggestions as to how I can go about fixing the internal mic?

1

My guess is that they accidentally disconnected the mic or failed to reconnect the mic when they operated on it.

MacFixIt has a guide if you want to try to take it on yourself. They rate is as "Moderate" difficulty.

Be sure to double check that I got the right model for your iMac.

Otherwise it's back to Apple it goes...

|improve this answer|||||
  • Thanks for the link. I will try it out and report back with results. – Engineero Aug 6 '13 at 13:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .