2

As someone who doesn't like to shout, I have Caps Lock remapped to Control on all of my computers. A second control key is far more useful to a guy who spends most of his time in Terminal.app. This was set up in System Preferences under Keyboard and Modifier Keys.

My MacBook Air (MacBookAir3,2) keeps 'forgetting' this setting every couple of days and reverting to SHOUTY CAPS LOCK. I haven't yet pinpointed when it is reverting. It happens more frequently than me rebooting the Air but less frequently than me closing and opening the lid.

I don't have this problem on my MacBook Pro, Mac Mini or iMac. All four Macs are running Mac OS X 10.6.6.

I've searched the web but to no avail; I've never connected an external keyboard, mouse or trackpad.

Help me, StackExchange Users, you're my only hope.

1

Try doing a 'repair permissions' in Disk Utility. A permissions error could be causing the preference to get overwritten by the default.

  • Good suggestion. I ran "Repair permissions" but nothing in the log suggested anything keyboard- or modifier-key-related was repaired. Lots of other things were. – Johnsyweb Mar 10 '11 at 8:50
  • One week on and I've not seen the symptoms since running "Repair permissions". Answer accepted, with many thanks. – Johnsyweb Mar 17 '11 at 19:26
  • Ah phooey! I spoke too soon! :-( – Johnsyweb Mar 19 '11 at 12:10
  • 1
    No problems since upgrading to Lion. Accepting this as the most useful answer as it certainly reduced the frequency. Thanks @dazmax. – Johnsyweb Aug 9 '11 at 22:36
0

just stumbled across this while looking for something else. Have you tried Double Command? Awesome, and free. Cheers!

doublecommand

  • Thanks for the recommendation. I'm more curious as to why one of my Macs is forgetting my preferences. Your answer may be helpful to others, though. – Johnsyweb Mar 10 '11 at 8:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .