0

I'm attempting to setup a VPN to my home by using a Windows 7 machine as a VPN server. I've set it up the standard Windows 7 VPN which I believe uses PPTP. I've also enabled PPTP passthrough on my router.

Problem is I can't seem to connect to the VPN and I get the following errors in my system log.

Aug  3 10:37:18 melonade.local pppd[6215]: pppd 2.4.2 (Apple version 596.13) started by philipgoh, uid 501
Aug  3 10:37:18 melonade.local pppd[6215]: PPTP connecting to server '192.168.0.4' (192.168.0.4)...
Aug  3 10:37:18 melonade.local pppd[6215]: PPTP connection established.
Aug  3 10:37:18 melonade.local pppd[6215]: Connect: ppp0 <--> socket[34:17]
Aug  3 10:37:18 melonade.local pppd[6215]: MPPE 128-bit stateless compression enabled
Aug  3 10:37:18 melonade.local pppd[6215]: MPPE disabled
Aug  3 10:37:18 melonade.local pppd[6215]: Connection terminated.
Aug  3 10:37:18 melonade.local pppd[6215]: PPTP disconnecting...
Aug  3 10:37:18 melonade.local pppd[6215]: PPTP disconnected
Aug  3 10:37:19 melonade kernel[0]: pptp_input unexpected, so = 0xffffff80493bcdc0, len = 21

It looks like the connection is established, but then it receives some unexpected data and terminates the connection. I'm assuming that the VPN is PPTP as I set it up using these instructions. I've tried Googling but I don't find anything helpful.

  • Who is on the other site ? a osx ? – Ruskes Aug 3 '13 at 12:14
  • The VPN server is running Windows 7. The VPN client is OS X. The log I attached is client side, from the OS X client attempting to connect to the VPN. – CadentOrange Aug 3 '13 at 14:37

You must log in to answer this question.

Browse other questions tagged .