I'm getting console messages multiple times per day that look like this:

8/2/13 5:20:00.119 PM postfix/sendmail[31004]: fatal: chdir /Library/Server/Mail/Data/spool: No such file or directory

When I tail /var/log/mail.log I see the same messages. According to the postfix config, the spool is indeed pointing to this directory, and yes, it does not exist.

queue_directory = /Library/Server/Mail/Data/spool

The thing is, I don't want postfix to be running, and have no idea why it's throwing errors. I'm not listening on port 25 as per netstat and I don't see any postfix processes running.

What's causing the error? Why would I get it if postfix isn't running?

1 Answer 1


Sounds like you have postfix installed and running.

You should check your postfix configuration.

There is a good description here.

Or do it your self: If postfix is still not working, check the log file in /var/log/mail.log for the error:

sendmail: fatal: chdir /Library/Server/Mail/Data/spool: No such file or directory

To fix this, run the following commands in Terminal:

sudo mkdir -p /Library/Server/Mail/Data/spool
sudo /usr/sbin/postfix set-permissions
sudo /usr/sbin/postfix start

If as you say you do not want it to be on your computer then disable it.

sudo /bin/launchctl unload -w /System/Library/LaunchDaemons/org.postfix.master.plist

That does not answer your question who is using it, but without more info from you one can not say, it could be a script in your system.

You could try to find out who is sending by going to

Open your Console:

Scroll down to Var/Log/mail.log

The background: Mac OSX comes with the postfix MTA, which is a fully featured SMTP server. Under normal circumstances, there is usually no need to enable or configure this software, as most email access is usually done via GUI clients such as the Mail.app – which uses the POP/IMAP and SMTP settings to connect with the email service provider. However, there are certain circumstances in which having a local SMTP server is very useful, such as: Allowing the batch logs and output from the cron daemon or other scripts to be sent via Internet email (this is otherwise delivered locally) Testing email based code; which requires a local sendmail like SMTP server to be present

  • Thanks for the response. I ran sudo /bin/launchctl unload -w /System/Library/LaunchDaemons/org.postfix.master.plist but a half an hour later received another of the same sendmail errors in console
    – Noah Li
    Aug 3, 2013 at 4:39
  • Try using the Fix as described above first to eliminate the error. Than we can go about finding who is sending the mail.
    – Ruskes
    Aug 3, 2013 at 8:39
  • Creating the directory and restarting / stopping postfix did indeed stop the console errors. Since postfix remains stopped, I guess nothing will be sending mail. Problem solved.
    – Noah Li
    Aug 5, 2013 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .