4

I have a MacBook pro that I got about 10 months ago. It seems like I am already starting to experience battery life issues. I have a charge cycle history of less than once a day since I bought it. I first thought it was too much stuff running in the background, so I put a fresh copy of Ubuntu on it to test that out. It still seems to have a bad life. At full charge, 50% brightness, the battery says 3 hours remaining, but then after a few minutes, it goes to 2 and I get an average of about 2.5 hours. I have appleCare. Is there a problem, or is time just going faster for me and the battery is normally like this? I think the battery said it usually has a good 5 years, and it hasn't been 1 for me. The battery indicator on status bar also never says 100%, and is usually stuck at 95-99 when the green light indicates full. Is this normal? Or do I have a bad battery? Is there a way to test my battery properly?

Here is what the power stats say

enter image description here

  • It's sound like you have a bad battery. As @Buscar said you should have many more cycles before the battery starts to behave like you describe. If I compare to my 3 year old MBP it does have better battery then what you describe. Good that you have appleCare! :) – Alex Jul 31 '13 at 7:36
1

There is detailed information available about your battery.

Click on Apple (top left)

About This Mac

More Info

System Report

Power

In the Health information it shows how many cycles you had so far. I have 142 cycles since Oct. 2012. The battery should last about 1000 cycles. If you have a problem please see Apple service.

enter image description here

Above you see some comparison data (from my MBA) Running @ 100% brightness, Mail, Firefox, Chrome, WIFI and more, consuming about 1200 mA. Unfortunately Apple does not show the remaining life as time, so you have to use a formula to calculate that, but it varies based on usage (mA).

  • I gave that information in my answer = October 2012 :) – Ruskes Jul 31 '13 at 7:44
  • I really need my morning coffee. :) So you have about the same usage as @Skyler 440 but not experiencing the problems. – Alex Jul 31 '13 at 7:47
  • I added the battery stats to my question. Does this look ok? – Skyler 440 Aug 2 '13 at 2:35
  • I would say your power consumption is abnormally low (or indicator not correct)? at -30mA ?? – Ruskes Aug 2 '13 at 7:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .