9

I've a Google account set up on a Mac of mine. OS X version 10.8.4 and everything else is up-to-date. And my Google account uses 2-step authentication.

I'm having a problem with my Google account on this Mac in the native Mail app. The problem is that when everything was working fine, one day, all of a sudden Mail asked for my Google password. I simply created a new application specific password. But after some time the same happened again and I ended up creating another application specific password.

Now it's happening again and it's kind of getting annoying.

Why does it keep asking for passwords when the one before was right and working? Has anyone else ever had this problem?

Also I should mention that my iCloud account, also set up on this Mac, functions perfectly.

  • Is the password still there? – Ruskes Jul 30 '13 at 17:35
  • if you mean that if the password is there or not when it asks me for a new password, then yes. it's still there but clicking OK doesn't do any good. otherwise I couldn't get what you mean – Can Sürmeli Jul 30 '13 at 19:30
  • Yes, in the mail profile for gmail, does it show the password. Do you get specific error or what exactly does it say? Is the problem only with mail or also when you try to log in in to google mail on the web? – Ruskes Jul 30 '13 at 19:53
  • No it's only Mail specific. Just basic error dialog saying that password is incorrect. – Can Sürmeli Jul 30 '13 at 21:25
  • Do you also have other devices (iPad, iPhone) set up to access this account via IMAP? If I recall there is a limit to the number of connections you can make to the GMail servers which result in a password prompt in Mail. – pknz Jul 30 '13 at 23:40
8

If you have several devices accessing your Google account via IMAP you can reach the limit of connections Google permits. The limit is 15 connections per account, however, bear in mind that each client can open multiple connections. In my experience the limit is easily reached with 3 devices. I have read that the Thunderbird email client has a setting to specify how many connections it can open, Mail and Outlook do not have this option.

Your Mail client should prompt you with a message along the lines of "Too many simultaneous connections." However I believe on iOS devices and Apple Mail you may see a more generic error.

The workaround for this issue is to log in to the GMail web interface, scroll to the bottom of the page and click the 'Details' link. From the popup window click 'Sign out all other sessions'

support.google.com/mail/answer/97150?hl=en

0

Open your keychain and delete all duplicates for gmail account leaving only the newest one.

Then run the Keychain first aid in verify mode first to see if you have any problems.

If needed run the repair.

  • I tried this but it didn't help. Even though my keychain needed a fix for a particular item related with my Google account, the problem wasn't related with this. After applying your method, I still experienced problems with using my Google account. – Can Sürmeli Aug 2 '13 at 7:09
0

This discussion talks about a similar problem, but even worse: the user isn't able to put in their password.

A few suggestions from that thread:

  • reboot
  • upgrade to OSX Capitan (the problem seems assocaited with Yosemite)
  • relaunch Mail
  • if relaunching doesn't work, try:
    • quit Mail
    • open Preferences->Internet Accounts - hopefully you won't need to log into your google account
    • launch Mail again

I've tried all of these except the upgrade and had them solve the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .