0

In macbook pro there is no lan port, for that I bought lan to usb connector.

But I am unable to setup net-connection.

In System preference > networks there is no ethernet option.

enter image description here

I tried this link https://discussions.apple.com/thread/4835488?start=0&tstart=0

  • As long it is not plugged in there will be none. – Ruskes Jul 30 '13 at 13:59
  • Ethernet connection not appears after plugging in. – TLE Jul 30 '13 at 15:12
  • Than there is no juice on the cable! – Ruskes Jul 30 '13 at 17:02
  • @TLE Please edit the title and content to clarify that you are using a MacBook Pro with Retina Display (or MacBook Air) and a Thunderbolt Ethernet adapter. – Shane Hsu Jul 31 '13 at 6:50
2

There's a add button at the bottom right portion of that screenshot. Click it.

It will present you with options to add a new interface, and if wired Ethernet is available on your Mac, it will appear there.

  • I tried that, but it doesn't show any Ethernet option . – TLE Jul 31 '13 at 5:07
  • @TLE Goto System Profiler and select Ethernet from the sidebar to see if any Ethernet device is available. Or if using USB/Thunderbolt adapter, try going to their respected section and see if the device is shown. – Shane Hsu Jul 31 '13 at 6:49
  • domosupport.com/download.php I am using U1 model of nhance product. I tried to download drivers of that product but didn't find dmg file. – TLE Aug 3 '13 at 13:27
  • This link has detailed information to installing kext manually. osxdaily.com/2012/01/12/… – Shane Hsu Aug 3 '13 at 17:17
  • Extract Archive.pax.gz file and you will get a kext file. You could install that kext file copying that to /System/Library/Extensions and then fixing disk permission with Disk Utility which will install that driver. This is NOT recommended, since that might crash your system. I will suggest buying a dongle that works out of the box, like ones from Apple. – Shane Hsu Aug 3 '13 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .