18

I have an Automator workflow and one of the actions is to clone a repository. Here's the code for the 'Run Shell Script' action. The command is run within the Bash shell /bin/bash if that matters:

SOURCEDIR="${3/\/Volumes/}"

cd "$2"
REPOURL="bob@somedomain.com:$SOURCEDIR"
WORKINGDIR="$1"

# Capture any errors with cloning process in log file
git clone "$REPOURL" "$WORKINGDIR" &> ./log.txt

// For debugging
echo "exit code: $?"
echo "PPID: $PPID"

open .

Now the Automator App runs fine on my machine. The path to git on my machine (A Macbook Pro) is: /usr/bin/git (I believe I installed git on my machine through Xcode)

But on my co-worker's machine (Also a Mac Pro) the Automator App fails. In fact, the output of the log.txt file says: bash: git: command not found

Now on my co-worker's machine the path to git is: usr/local/git/bin, which, yes, is different because he installed git through the Google Git Installer for Mac OS X, but I didn't think it should matter because in the script the git command is not absolute path to the command and further more my co-worker can run git normally from a Bash script but when invoked directly from the Terminal.

So what gives? Why does the automator workflow work for me but not for my co-worker?

There must be something fundamental about Bash or Unix that I'm not understanding here but I'm lost.

35

Scripts run via Automator use the default search path which usually does not include /usr/local/bin. In your case an easy fix would be to put

export PATH=/usr/local/bin:$PATH

somewhere at the beginning of the script.

  • I actually tried shortly thereafter and it didn't work either. – racl101 Jul 29 '13 at 22:22
10

For a more general solution to the bash environment in automator differing from your own you could simply load your personal bash profile at the first line of the automator bash script:

source ~/.bash_profile

This will make the path and any other environment variables you're used to using available from your automator script.

  • I much prefer this solution. A good overview of the bash login scripts is here – Jay Jun 18 '16 at 22:40
4

I solved the same problem of the same "service" workflows being run on differently configured machines by checking what happens when the terminal starts the shell and eventually adding the following snippet to the top of all my "Run Shell Script" actions:

if [ -x /usr/libexec/path_helper ]; then
    eval `/usr/libexec/path_helper -s`
fi
if  [ -f "$HOME"/.profile ]; then
    source "$HOME"/.profile
elif [ -f "$HOME"/.bash_profile ]; then
    source "$HOME"/.bash_profile
elif [ -f "$HOME"/.bashrc ]; then
    source "$HOME"/.bashrc
fi

This covers all the cases I've encountered so far.

1

If you want the Workflow to work on both machines that have git in different locations, then add each location to the PATH variable that patrix mentioned, separated by a :, as explained here: https://developer.apple.com/library/mac/documentation/AppleApplications/Conceptual/AutomatorConcepts/Articles/ShellScriptActions.html

So, at the very top of your Workflow Shell Script, you would add:

PATH=/usr/bin:/usr/local/bin export PATH

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .