4

Unicode characters appear in regular old vim in the terminal (iTerm), but not MacVim. Is there a way to get MacVim to handle Unicode characters appropriately. If it helps, I installed them using homebrew.

I grabbed these lines from the Vim Wiki:

if has("multi_byte")
  if &termencoding == ""
    let &termencoding = &encoding
  endif
  set encoding=utf-8
  setglobal fileencoding=utf-8
  "setglobal bomb
  set fileencodings=ucs-bom,utf-8,latin1
endif
  • What exactly is MacVim doing wrong? Unicode works fine on my install in both GUI and Terminal (mvim -m) mode. – Mark Reed Sep 13 '14 at 2:44
5

If you mean that Unicode characters don't render correctly try disable the "Use Core Text renderer" option in the "Preferences… → Advanced" menu and restart MacVim. (source 1, source 2)

I have a similar problem, in which emoji charachters are rendered to big, but as of yet I don't know how to fix it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .