1

I have been using a matrox TripleHead2Go DP (work) and DualHead2Go DP (home) with a late-2010 Macbook Air (Nvidia GeForce 320M graphics) with two Dell 2007fp monitors at 2*1600x1200@60Hz (i.e., one large display spanning both monitors with MacBook Air closed).

With a mid-2013 Macbook Air the same monitor setup was autodetected as 2*1600x1200@50Hz, which isn't supported by the monitors. Manually switching to 2*1600x1200@60Hz leads to mirroring of the displays in the two extermal montiors at 1600x1200 (macbook closed). Changing to lower resolutions will allow the desktop to span both monitors with the macbook closed but isn't ideal.

I couldn't find anyone else with a similar problem. Matrox customer support blamed the new Intel 5000 GPU in the new Macbook Air and had no further suggestions to fix this issue. Has anyone encountered this problem with the new mid-2013 Macbook Air and the Matrox Dual/TripleHead2Go DP unit(s) and have a work around?

The matrox units have the latest firmware updates, and I'm using the most recent version of the PowerDesk software from matrox.

  • You could try a Gefen DVI Detective to spoof the EDID to 3200 x 1200 @ 60 but you would need your old setup to steal the EDID from. there are also software EDID options available but none that I can recommend atm, also not sure what the Intel 5000 would do. – hoss Jul 28 '13 at 13:31
  • @hoss; I like your suggestion to try to steal the EDID signal. I don't see a Gefen DP device available (also, it's planned to be sold for ~$300, which isn't a workable solution for me). I can probably just use the old Mackboo Air to get the EDID and give that to the new Macbook Air, i.e., ioreg -l | grep -F "IODisplayEDID" – user54061 Jul 29 '13 at 3:41
  • Nothing has worked so far. Apple kind of agreed with Matrox that it's "something to do with the hardware." Here's what I tried: 1) I used the working MacBook Air to grab the EDID for the extended display. Using the following guide: insanelymac.com/forum/topic/… 2) called apple support reset boot RAM parameters by powering down mac pressing command+option+control+power_button for 1 sec then held down command+option+P+R while powering up - waited for two chimes and then let go of keys and logged in. – user54061 Jul 29 '13 at 21:19

You must log in to answer this question.

Browse other questions tagged .