0

How can I set sharing and permission on Mac os x to be -rwx for all? When I create file or folder it is read and write for me but for all others it is Read only. If there is more files just copied from USB to some unlocked folder, automatical it is read only for all other users. Because we share files it is annoying. So please help.

2
  • 2
    Please clarify. Do you mean other users on same computer?
    – Ruskes
    Jul 27, 2013 at 17:54
  • Assuming local shares try chmod ugo+rwx <name of file>. chmod can effect multiple files with options, check man chmod for more information.
    – hoss
    Jul 28, 2013 at 13:44

1 Answer 1

2

Set your umask to 000 and reboot, then all files will save with full permissions for everyone. Here is the documentation http://support.apple.com/kb/ht2202

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .