1

When I got my Mac Mini with 4GB RAM I thought it would be enough, since on my Windows machines I never hit past 3GB – but I was wrong. So I ordered 16GB of RAM, but one of the sticks was bad, so I have 8GB in one channel and 2GB in the other, totalling to 10GB RAM.

Normally this is more than enough to have a virtual machine open, whilst playing games and doing some heavy work at the same time. Today I finished recording a video and started to encode it on ScreenFlow when I realised it said it would take an hour! It normally takes a few minutes, so I opened up Activity Monitor and saw all of my RAM was being used!

I never saw that before – I only had ScreenFlow open by itself. After looking at the processes, I noticed there was nothing major hogging up the RAM, so what gives?

It's the first time this has happened! I saw a page out since putting the new RAM in as well. Why is everything so slow? This is my first Mac, so I hope I don't have to fiddle around with something like a registry or anything. I am willing to answer any questions and do any tests.

  • See: apple.stackexchange.com/questions/52013/… It doesn't actually provide an answer, but it explains what's going on. I've been having the same problem at least in Mac OS 10.6 and 10.7 (and maybe 10.5) – Eric Jul 27 '13 at 12:44
  • Looking at your previous screenshot, it looked like you were doing some intensive I/O work. All I/O eventually goes through the kernel in some way, and that can lead to increased kernel memory usage. Looking at my memory usage, my kernel is hovering above 1GB. – CyberSkull Jul 28 '13 at 1:08
3

Dont worry about the inactive part, this doesnt mean that your mac will run slow, macintosh keeps these inactive(as IDLE) where when programs needed*-(the ones that you've been using)-* then accessing them would be faster since they are still in a way or another in memory regardless of swapping being in process.

And if your scared of the inactive blue color eating the pie chart displayed, then open your terminal and type: "purge" to clear your inactive space.

  • 1
    Holy smokes... was noticing this problem as well in my iMac with 32GB of physical RAM that is constantly maxing out. I just tried a purge for the first time and my current active usage (many of my normal apps not running) went down from over 24GB to under 14GB! – Jonathan van Clute Nov 25 '14 at 4:34
0

Expanding on my comment above:

See: apple.stackexchange.com/questions/52013/why-is-it-that-my-mac-would-rather-swap-than-clear-inactive-memory?rq=1 It doesn't actually provide an answer, but it explains what's going on. I've been having the same problem at least in Mac OS 10.6 and 10.7 (and maybe 10.5). The only "fix" I've been able to find is to manually clear the memory cache when this happens. I know of two ways to do this:

  1. If you have the Mac Developer Tools installed, the command flush on the command-line will flush the memory cache and make some (often most) of the inactive memory active.
  2. The utility cocktail (and probably others) have an option to Purge inactive memory and optimize virtual page usage which seems to have the same effect.

I think there's been some debate around this, but personally I don't understand why the memory manager keeps so much inactive memory unavailable while the system starts swapping.

  • 1
    Hello Eric. I normally use the purge command in terminal to lose some inactive memory. I don't recommend people to do it all the time though, and apps are a bad idea. OSX was only using around 5GB of ram as inactive, I just don't see how the rest ran out with just a few apps open. I don't really see why I should throw in another 8GB of RAM. Why can't Apple make OSX handle RAM like GNU/Linux? ._. – osxipro Jul 27 '13 at 13:01
  • I ask myself the same question. It seems fundamental in a memory management system. I've heard some say it's working as designed, but I can't see how it could be, if it forces swapping. – Eric Jul 27 '13 at 13:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .