4

I have consistently been having a problem with my computer overheating due to random processes using 100%+ CPU. Commonly the problem occurs with the process QuickLookSatellite-general, but it is not limited to it. (Please see images below.)

When the QuickLookSatellite-general is the process in question, resetting the Quick Look Manager:

qlmanage -r

…seems to solve the problem. Otherwise the problem continues until the application is closed or the process decides to stop.

QuickLookSatellite-general 196.4% CPU

QuickLookSatellite-general 200% CPU

On Google I found this process is associated with DraftSight, a CAD program. I do not and have never had this program installed.

Restarting does not even fix this problem. It makes my MacBook completely unusable as I do not want it to be damaged running at 90℃.

Any assistance is appreciated.

Thanks!

EDIT *** Addition, found disabling/resetting mdworker helped substantially

sudo mdutil -i off /
sudo mdutil -E /
sudo rm -Rf /var/folder/*
Reboot
sudo mdutil -i on / (I just left it off.)
  • Good job in narrowing it down. It is possible that the Draftsigh was a part of package of another program. – Ruskes Jul 26 '13 at 19:19
  • Gotcha, anyway to check for this? Heard of any other person having this problem? Someone suggested it may be malware :/ – andrsnn Jul 26 '13 at 19:22
3

To see what generators QuickLook has installed, open the Terminal (Applications/Utilities/Terminal.app) and run the following command:

qlmanage -m

This will give you a quick dump of what is loaded at the moment with QuickLook. Also pay attention to what directories you have open at the time your CPU spikes (QL doesn't generate thumbnails for anything other than a directory or file being displayed in the Finder or other application viewing a file list).

It will output something like this

[uniform type identifier] -> path (version) [uniform type identifier] -> path (version - loaded)

The -m flag also accepts several arguments:

  • plugins Show the generators list (default action)
  • server Show quicklookd life information
  • memory Show quicklookd memory consumption
  • burst Show statistics about the last burst
  • threads Show concurrent accesses stats
  • other Show other information about quicklookd

Additionally, don't bother with man qlmanage as the manual isn't as good as the built-in help found at qlmanage -h.

If you want to see if DraftSight has a plugin loaded (or installed), try running qlmange -m plugins | grep -i "draftsight".

  • 1
    Thank you very much for your assistance. I did not find the draftsight plugin loaded. I will definitely use this in the future. – andrsnn Jul 29 '13 at 22:45
  • 1
    I also found resetting/disabling mdworker improved temp stability as well. Seems to be running a good 6 to 10 C cooler on idle! – andrsnn Jul 29 '13 at 22:45
4

It's a bug for sure, but the root-cause is a cached search in Finder which tries to find every file on the system and runs out of resource handles or something. It's an obvious use-case in Finder that I'm astonished nobody has spotted yet (but I have been a Unix/Linux system developer for 20 years).

When Finder is doing it, you can both get rid of the phantom 'suck search' immediately, but also fix it permanently with 2 button clicks:-

When you have the issue, on the finder menu bar, you'll see the 4 icons pertaining to switching views, list, columns, coverflow, etc.

Just click one of the buttons once to change the view to something else from your usual default, then click the button pertaining to your default view preference to change it back.

You should notice 3 things:-

  • The CPU-spin stops immediately and normality returns.
  • The phantom stuck search gets removed
  • It doesn't happen again - of course until you exercise the Finder design flaw (that's been there, what 7 years now!?!?) again. Just repeat until somebody wakes up and figures it out.

-Al.

  • I cannot believe this actually worked for me, still a bug on Sierra! – Kenneth Hurley Jan 24 '17 at 17:57
1

I had the same problem. It was caused because I left open a Finder window with a Search which seem it kept refreshing all the time.

I just closed that finder tab with the search and the 100% CPU dropped to a normal 3%, and the quicklookd process dissapeared from System monitor's list

0

What I also found helpful was to turn on QuickLook debugging so I could see exactly what files were being processed. You can do that with this in the terminal. More info in the Mac Developer Library.

defaults write -g QLEnableLogging YES

You can also adjust the debugging level using qlmanage -d debuglevel. Run qlmanage -h for more info.

In my particular case it was QuickSilver causing the issue, which I fixed by disabling image previews using this command in the terminal. My thread on that is here.

defaults write com.blacktree.quicksilver "QSLoadImagePreviews" NO

Also see this similar superuser question.

0

I encountered this problem too. I looked it up it is probably some corrupted cache. go to /user/yourusername/library/cache/com.apple.QuickLookDaemon/ and clear the cache.

  • Can you edit your answer and provide a link to where you looked it up? What steps/commands are necessary to clear the cache? – Greenonline May 15 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .