2

I recently downloaded Mountain Lion because I wanted to be able to send and receive iMessages from my phone number on my MacBook Air. But, for some reason I'm not able to add my number to my Mac. When I send a text from my Mac, the receiver gets a message from my apple ID not my phone number. I've tried to go the Messages and the Message Preferences but my Message Bar doesn't even have a Preferences tab. I've also tried going to Settings and accessing my Messages Account but I can't find it. I just really want to be able to send a message to my friends from my phone number on my laptop.. Can anyone help?

  • So say I don't want to have texts coming to my phone to also come through on my laptop. Can I just uncheck the box next to my phone number on the computer, and that will mean texts won't come through my computer anymore? – Hogan Warlock Oct 1 '17 at 19:27
  • @HoganWarlock I have deleted your 'answer' as, well, it's not an answer, just another question. But yes, that is how it should work. – Monomeeth Oct 1 '17 at 20:58
5

This is simple to accomplish if you have an iPhone to associate your phone number with your Apple ID account. I'm not aware of any way to hack, trick or cajole Apple to add a cell phone number to an Apple ID other than it going through the normal activation process on iPhone only.

  1. Activate your Apple ID - http://support.apple.com/kb/TS4268
  2. Open iMessage on the Mac and in preferences, set the caller ID to initiate messages from your phone number instead of your AppleID email.

enter image description here

As you can see, it is allowed to add more emails to an Apple ID, but the adding of phone numbers happens when you activate things from a live phone account and SMS messaging verifies that the phone number matches the iPhone.

Once that's done, Apple is happy to let your Mac or iPad or phone "iMessage" from that telephone number.

0

You cannot send it from a phone number on your laptop, unfortunately it has to be from your Apple ID. Your laptop does not have a SIM card in it.

  • It kind of sucks, but theres really no way for apple to make it work like that. – qaxf6auux Jul 24 '13 at 22:18
  • If it's important for you to be able to send messages from your phone number on your computer, you'll have to use a different service than iMessages. I've seen various services that claim to support this, but the only one I've used in the past is Google Voice. The downside of it is that you have to port your number from your cell carrier to GV or start using a new number. – Wesley Bland Jul 31 '13 at 19:52
0

First, I recommend checking out this question and answer as you may find configuration issues on your phone itself. It is easiest to setup if you are on iOS 6, but will work if you are on iOS 5.

Based on your mention that friends receive messages from your Apple ID, I concur that (1) at least something is working properly on your end, and that (2) your friend is using iMessage as well.

There are two ways to open the preferences dialog in Messages.app. The most straight-forward is to click the "Messages" menu in the upper left corner of the screen. You could also use the keyboard shortcut which is + ,.

Likely your biggest key will be to initiate conversations from your phone number. You can do this by selecting, and changing the Start new conversations from: drop down menu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .