2

I can't get web pages to load on my MacBook Pro. Airport connects with the router and ping tests work fine (on www.google.com) but web pages aren't loading in any browser in any user account. Internet works on all other devices.

Worked fine until yesterday when it just stopped working.

Update:

Very strange. I tried three routers and had the same problem with all of them. I then created a new admin user account on my Mac and the internet worked on it. When I returned to my own account - the internet was working again!

Any idea why this would happen? It seems creating a new admin account and then coming back solved it.

  • 1
    What browsers are you using - if only Safari try another – Mark Jul 24 '13 at 20:53
  • Tried Safari and Chrome. – Kieran Jul 24 '13 at 21:00
  • 1
    Did you accidentally turn on the parental control on your account ? That would block using Internet. – Ruskes Jul 24 '13 at 22:00
  • Something was probably messed up with the browser settings, considering it worked from terminal. You (or some script or update) probably messed with the proxy settings, which meant you couldn't load pages. – Flare Cat Jan 20 '16 at 1:48
1

Try looking in the System Preference/Network panel for your active network connection. Highlight the connection, click Advanced, then check the different tabs to see if any information is statically entered. Specifically, check under Proxies. Any sort of manual override under your account could be at fault.

1

Deleting the wifi icon and shutting down fixed the same issue for me as well

  • Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. – fsb Jun 29 '17 at 21:34
  • Deleting and shutting down the mac fixed it for me as well. Many thanks for saving me from the frustration – Badru Mugerwa Jan 22 '18 at 23:58
0

Did you flush your DNS cache?

In 10.6, and prior, the method was to issue

dscachutil -flushcache

from a Terminal prompt.

But on Lion and Mountain Lion it's different:

What works under 10.7 and forward is:

sudo killall -HUP mDNSResponder

  • Did not work for me :( – Michael Mar 3 '14 at 1:45
0

Try a new DNS server, use Open DNS numbers and see if that doesn’t get you fully online with 10.9.2.

  • So what are the number the DNS numbers then.. – markhunte Dec 28 '14 at 13:36
  • 1
    Useless. Since the OP signaled to be able to ping www.google.com, this was in no way a DNS related problem. – dan Mar 4 '15 at 13:32
0

I had the same problem; I tried everything and nothing seemed to work! Fortunately I solved the problem after many disappointments; I hope it works for you too.

Here's what I did: I went to network preferences, on the left side you can see a WiFi icon. I chose it and then deleted it, then turned off my Mac (I didn't restart it, I just turned it off) and then turned it on again. Then again I went to network preferences and clicked on the + to add a connection, then chose WiFi to create and then my problem was solved.

You must log in to answer this question.

protected by Community Jan 26 '18 at 22:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .