I'm getting the error

Error downloading image.
iPhoto cannot import your photos because there was a problem downloading an image.

when I "Import All..." from my iPhone. Trying to import individual images I get

The following file cannot be imported. (The file is in an unrecognized format.)

In the past I've been able to do this, so I don't know why I'm getting grief now. Anyone have any suggestions?

To help describe the problem I've created a screencast: http://screenr.com/CLr

  • I've had this problem recently as well. I think the iPhone 4.0 changed the way it stores photos on disk, and it seems to be incompatible with iPhoto 9.
    – AlBlue
    Nov 9, 2010 at 10:38
  • 1
    Having the same issue. Phoneview, as noted in Vijay's answer, actually works fine and is able to import images, but it has a limit of 20 in it's free version, and I'd rather not pay 20 bucks for a fix here. I've also tried to import via Preview, and while it's as fruitless as through iPhoto or Image Capture, the error message is somewhat more enlightening: "The operation could not be completed. (com.apple.ImageCaptureCore error -9912.)" Googling the error message turns up similar issues around the web, but no solution. Jul 7, 2011 at 5:36
  • I have problems like this in a regular camera as well, not only iphone cameras... Jul 8, 2011 at 1:50
  • As a Test: Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library' Import a few pics into this new, blank library. Is the Problem repeated there?
    – terrydev
    Jun 25, 2012 at 6:10
  • I had this problem with both iPhoto and Image Capture when I was trying to import 10 GB video from my iPad. Somehow I tried AirDrop and it worked! The video was saved to Downloads folder. [I wish I could post this as an answer for a better visibility]. Feb 20, 2016 at 21:27

14 Answers 14


I seem to have resolved the issue by connecting my iPhone 4 directly into my MacBook as opposed to using a USB hub which I connect everything to.

edit: I also found this to be the case after a long term problem with importing photos/films from my iPhone 5; it was intermittent and buggy, but I was using a simple USB extension cord from behind my computer and eventually removing; because of this, this answer solved the entire issue.

  • bingo! could also be related to my starting to use a non-apple cable in said hub
    – spiral
    Oct 20, 2014 at 18:35

May be you can try using http://ecamm.com/mac/phoneview/ Phone view to get the image copied over to your Mac, and check if the file is corrupted.

  • 1
    PhoneView succeeded for me where Image Capture did not.
    – emmby
    May 27, 2012 at 19:00

Surprising enough, after spending two hours crunching Google to find an answer, and restarting my phone (Home + Power key), the only solution was to restart my Mac. It solved everything magically (both Picasa and all other softwares)

  • Glad I found this answer and decided to try such a simple thing. A restart fixed it for me too. When it doubt, reboot!
    – JVC
    Mar 3, 2019 at 19:01
  • This one for me as well. Could be an issue if you are low on space and files are de/syncing to cloud.
    – Jecoms
    Jan 3, 2021 at 22:00

It's hard to tell which of two things is the real issue:

  1. The Phone has some corrupt pictures.
  2. The databases on your Mac used to track which pictures are imported are corrupt / iPhoto is corrupt.

You can rule out #2 by taking the phone to another mac (or at least make another user on the same mac to try an import from a clean slate).

As has been mentioned before - if the pictures are corrupt on the iOS device, you will have to spring for PhoneView and perhaps a tool like Data Rescue to see if the photos are salvageable. Often JPEG headers and such are bad and the image data is fine or patchable with little or no visual evidence of the corruption.

Also - it could be a combination of both #1 and #2 which is why some work under PhoneView and others don't. Lastly - you could try restoring that backup onto another iOS device and importing the photos from there. It would rule out a problem with the phone which is highly less likely than the other two items listed above.

  • And if I were betting on it - my guess is the image capture cache is corrupt, so do try making a new user and use image capture to grab any or all of the photos. You can skip the error ones and get the rest easily. Deleting space on the iPhone as you go in case it's totally full.
    – bmike
    Jul 7, 2011 at 21:39
  • Is there any good way to delete the image capture cache if in fact that's the issue? Jul 8, 2011 at 12:15
  • I haven't traced which folders and files are related for some time. Making a new account was faster for me to bypass that history to clean up the offending photos / rule that out as a cause / get the pictures I wanted. In my case, once I deleted the photos from the film roll - the cache worked itself out on it's own.
    – bmike
    Jul 8, 2011 at 16:52
  • 1
    There appear to be cache database files in /Library/Caches/com.apple.ImageCapture* - so if you wanted to experiment after a good backup of the mac, delete or move those and reboot to test that potential...
    – bmike
    Jul 8, 2011 at 17:01

One item not yet mentioned is that your hard drive could be full. I was getting this error until I made some space.

  • This solved for me, even when I had more free space than the video size (16GB vs 10GB). Releasing more space did the trick.
    – Nighto
    Oct 31, 2019 at 17:43

+1 for Phoneview for being a great app, but I understand not wanting to buy an app.

As an alternative, you should look at this fee app, it seems like it will do what you need.


Your best bet is probably going to be to get all the photos off of the iPhone you want/need by dragging them to your desktop/folder. Then import them into iPhoto.

Then do a backup of your phone in iTunes. I'd wipe the iPhone and re-install iOS via iTunes. Then once the operating system has been installed, iTunes will ask if you want to restore your backup.

If there is an issue with your photos/data then this may not help. However, if there is an issue with the underlying iOS then this may fix things for you.

  • This worked, but after doing this and clearing the Camera Roll, I still have the same issue with new photos. Keeping the bounty open in hopes of a more permanent solution showing up. Jul 8, 2011 at 12:18
  • If new photos have the same issue - it's a corruption in the photo roll (iOS needing a restore and set up as new) or corruption on the Mac in one of the databases tracking the iOS import status. Which of the two is easier for you to rule out?
    – bmike
    Jul 13, 2011 at 22:59

I have read in Apple's Support Forums that the Image Capture app (which is included on OSX, in the Utilities folder) will import these "corrupted" photos okay while iPhoto will not.

Like others, I'm still waiting a permanent solution (even an acknowledgement) from Apple.

  1. Close iPhoto make sure their isn't a white light appearing under the icon.
  2. Go to your pictures folder and drag the iPhoto library icon onto your desktop.
  3. Open up iPhoto and click on create new library.
  4. Once it opens, move it so you can see the iPhoto library icon on your desktop.
  5. Right-click on the iPhoto icon and click on 'Show Package Contents.'
  6. Drag the files Library.iPhoto and Library6.iPhoto onto iPhoto.

It should be working after that.


I've found iPhoto can be picky when it comes to things like color formats. For example, iPhoto returned the same error when I tried importing an image that was in Grayscale. I had to convert it to RGB first before iPhoto would import it. I've read elsewhere that iPhoto can also be picky about layers.

  • 2
    It would be pretty hard to get a bizarre photo in the film roll on an iPhone. Importing from finder is one thing, but iOS is pretty rigorously controlled as to what photos are importable.
    – bmike
    Jul 7, 2011 at 23:50
  • It's not hard at all. You just save a photo from Safari. I do this all the time.
    – Trieu
    Jul 24, 2011 at 18:10

Update! update! update! Make sure both your iPhone and Mac are on the latest versions of OS X (10.6.8) and iOS (4.3.3). Also, (if it's possible) upgrade to iLife '11.

If that doesn't fix your problem, try backing up (through iTunes) and restoring your iPhone. Also, try using photo syncing (through iTunes) instead of manually copying over the photos.

  • Everything is up to date on the phone, and the Mac in question is brand new (~1 month old) and is up to date as well. Photo syncing is for sending pictures in the opposite direction. Again, this problem is specifically with importing from the Camera Roll folder. Jul 8, 2011 at 12:16
  • Try restoring your iPhone. (Make sure you back up first!)
    – spudwaffle
    Jul 8, 2011 at 16:43

There's a problem importing photos from the iPhone (4S) to iPhoto; some photos are getting corrupted during the import process. It appears to be well-documented here.

  • While this may answer the question, it is best to summarize the contents of the link and provide the link for reference. Links have a tendency disappear over time, leaving a non-applicable answer for those who may stumble upon your answer in the future.
    – daviesgeek
    Aug 3, 2012 at 6:23

Hmmm... I tried some of the suggested solutions here and ultimately I decided to simply free up my hard drive a litte bit. So, I deleted some old photos and movies and voilà --- no more error message. :)


Try Disk Utility to check/repair permissions on the volume holding the iTunes library.

  • 3
    This won't fix permission issues in the user folder which is presumably where the image capture data is stored before the pictures get introduced into iPhoto. It's unlikely the Apple software has permission issues as the apps work with other tools so this shouldn't hurt, but likely won't help either. It would show a faulty hard disk or severe directory corruption, but I would expect a whole raft of other problems if that were happening.
    – bmike
    Jul 7, 2011 at 21:37

Do you really need IMG_0301.JPG ?

If not you could try clicking 'Delete' instead of 'Keep' to empty the library and hopefully get rid of IMG_0301.JPG and then sync the photos back to the phone if required.

  • IMG_0301.JPG was just an example. Trying random photos from various months yields the same result.
    – etoleb
    Sep 1, 2010 at 14:20
  • 1
    @gnuchu has a good point. splitting the bad from the good is viable - especially if Image Capture has the same errors (it's certainly faster at importing pictures to the finder and easier to clear out the good ones once they are safe). Once you know how many pictures are bad, you can be more certain it's a bad picture or two in the roll instead of an iPhoto issue.
    – bmike
    Jul 7, 2011 at 23:52
  • It's all 235 images in my case. Jul 8, 2011 at 12:17
  • Another option is to jailbreak your phone. ssh on to the device and then scp all of the photos from var/mobile/Media/DCIM to your machine. Then you can delete them all and hopefully be rid of this error. Make sure you back up pre-jailbreak. I used jailbreakme.com the other day and it is seemless (although I have iPhone4 running latest version of iOS). If you want to un-jailbreak post fix then it's as simple as a restore using iTunes. YMMV.
    – gnuchu
    Jul 11, 2011 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .