When I want to create a new file through the button (left-bottom one) in the project drawer or in the file menu it takes a long time and blocks TextMate and even blocks TextMate totally in some cases.

I've installed the latest version of TextMate and installed all updates available for Mac OS X.

Anyone any idea what the problem is?

  • Can you list the file hierarchy you have under ~/Library/Application Support/Textmate? Especially the Bundles, Pristine Copy/Bundles and Plugins folders. Aug 17 '10 at 20:55

I just tested it with a couple of different massive projects on my MBP and it created a new file right away.

First guess would be perhaps a bundle or other plugin you've added is interfering with the program operation somehow. You could also try trashing your Textmate preferences file and restart the program to see if that helps (~/Library/Preferences/com.macromates.textmate.plist).

  • I did what you proposed but it only made it worse. When I start Textmate it blocks immediately. What I did before the problems started was changing the computername. I don't know if that has anything to do with it. It sounds odd that that could be the problem. Aug 18 '10 at 10:07
  • Hrm. I'm not really sure what the issue could be, then. I don't know offhand if changing the computer name could affect TextMate or not. Have you tried changing the computer name back to what it was originally? Maybe try this: create a brand new user account on your computer and launch Textmate in there to see if you can replicate the problem? That would at least help narrow down if the issue is related to something in your Home directory or not.
    – Scott
    Aug 18 '10 at 10:12
  • Thanks Scottie that was the solution. Although I am not sure what the cause is but creating a new user and working with that solved the issue. With the "bad" user there was also something bizar with the terminal. If I have the time and more experienced I definitely going to find out what was the cause. I've transfered everything to the new user and work with that now. Aug 19 '10 at 11:52

Do you have any external drives connected? Certain external hard drives will go into some sort of dormant mode when they haven't been used in a while, and will block things until they spin back up. This is triggered by anything requiring filesystem access, whether you're trying to access those drives or not.

If this is your issue, it'll be very intermittent, and caused by other attempts to access the file system (Open File and Save File dialogs being common). Furthermore, it won't be limited to just Textmate, but your usage patterns may mean it mostly shows up there.

The solution, in this case, would be to unplug the external drives when not in use.

Of course, this isn't to say this /is/ your issue, but it would more or less fix your symptoms.

  • Nothing attached to it. I am only connected to my Time Capsule. Aug 18 '10 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .