0

My 2007 MacBook (10.6.8) worked perfectly fine with my AirPort Express, until I added a 2010 iMac (10.8.4) to the network.

When I first setup the iMac it connected to the AirPort Express, but not to the internet. The AirPort menubar icon showed an exclamation mark on it. At some point in or after the setup I was prompted to set up my AirPort Express, which had already been configured and working just fine with my MacBook.

I followed the instructions and the AirPort Express restarted. It worked! My iMac was/is now online. However, when I went back to the MacBook it was now showing the same exclamation mark on the AirPort menubar icon that the iMac had initially showed.

I have tried restarting the MacBook, the AirPort Express, and the iMac. I've disabled and enabled the AirPort on the MacBook. After each attempt the MacBook connects to the network and a few seconds later shows the exclamation mark when it fails to receive an IP address.

Wanting to dig into the router settings I opened up AirPort Utility on the iMac but got an error message: "This version of AirPort Utility doesn't support this base station."

Is the problem a compatibility issue between 10.6.8 and 10.8.4? Or 10.8.4 and the older AirPort Express? I'm confused by this since the MacBook did work perfectly fine before, when the iMac did not, and now that the iMac does, the MacBook does not.

Does anyone know what is going on!?

marked as duplicate by nohillside Jul 21 '13 at 12:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Setting the AirPort Express b/g to g-only mode solved this problem for me, though I don't understand why.

Not the answer you're looking for? Browse other questions tagged .