I'm mid way through replacing the hard drive in my MacBook Pro (mid-2009). I've created a boot disk (10.8) on a SD card which I am booting from.

On trying to format the new drive with disk utility (in from the installer) I am being presented with the following error.

Disk Erase Failed
Disk Erase failed with the error:
Unable to write to the last block of the device

Googling suggests this error message is somewhat ambiguous. The drive is brand new and from disk utility the SMART status is "verified".

Thanks in advance

2 Answers 2


The solution was really rather simple. A dead HD cable causing the HD to show up (and verify) but not function.

  • I am having the same issue, any advice?
    – lomse
    Oct 8, 2014 at 12:10
  • 1
    In my case it was the cable. If your problem is being caused by a dodgy cable you will need to replace it. On my model you aught to be able to replace the cable without taking anything out. Just open up the back, using a plastic tool prise the cable end off of the logic board, the other end (the bit which attaches to the hard drive) can then be removed.
    – osnoz
    Oct 9, 2014 at 16:55
  • 1
    If you cannot get at the hard drive end or if the cable goes under the hard drive or its assembly you will need to remove the drive itself. This in my case required a tourq 5 screwdriver (cheep on ebay). When buying the new cable be cautious of cheep imitation cables on ebay, I was advised to bite the bullet and slash out on a genuine part.I cannot guarantee that your problem is definitely caused by a dodgy cable, you could have a duff hard drive on your hands. If you have the ability to test that hard drive with another computer do try it out.
    – osnoz
    Oct 9, 2014 at 16:57

'unable to read last block of device' is a generic error.

for me i ran into this similar error, but specifically: Error: -69760: Unable to write to the last block of the device.

If you get this specific error it seems to be due to the block size that the drive was formatted in. Macs do not seem to play well with discs formatted with higher block sizes.

The default file size when i formatted an SSD as exFat32 using my windows surface was 4096kb and this would not play nice with my mac, causing this blocksize error when attempting a format.

This answer suggests 128kb unit allocation size format (i assume they mean cluster size). The minimum block size i could format with using my windows surface device was 1024kb and this worked for me allowing me to then use as exFat32 with the Mac.

However with the particular SSD device i bought, it only allowed me to do a quick (not full) format (on windows), and mac would still not allow me to then reformat as APFS, but at least i had a working storage device that my mac allowed me to read and write to. This was a cheap SSD so its possible it had been preformatted badly causing these limitations. The cable i was using to connect the SSD was new and decent so i dont see that as what was preventing a full erase/format.

The only problem is that i cannot store files larger than 4GB as i couldnt reformat as APFS, but i think this is probably a limitation of the cheaper device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .