A colleague at work has recently bought a MacBook Air (13-inch, Mid 2013) and instantly asked me to put Windows 7 on it as they don't want to start using Mac OSX. They also don't want to use Windows 8 - which will become relevant a little later! We have a MSDN account so I am able to get a licence key for either easy enough, so I downloaded the iso for Windows 7 Ultimate N 64bit and burnt it to a DVD.

I then installed Windows 7 (as I have done many times on Mac products) using the Boot Camp Assistant and got to the point where you setup the computer and username. Until this point there was no issue, but now the keyboard and mouse were non-responsive. From reading around this is apparently because Windows 7 doesn't come with USB3 drivers on the install disc and so it cannot recognize the peripheral devices (although I'm not convinced by this). Apparently installing Windows 8 can support this and would be a breeze...

I decided to try the building a flash drive method. After serveral attempts (the windows support update drivers never worked) I had managed to get a drive built and booted from it, installed it all again and as before I couldn't control the keyboard or mouse at the install screen. According to Apple, this can be caused when using a USB 3.0 flash drive, however I'm 99% sure that the one I was using is not (it's a cheap chinesey thing, says nothing about USB 3.0 and works in USB 2.0 ports on other machines).

Anyway, so I read a method someone else had luck with using DVD and then installing the trial version of VMWare Fusion to complete the install. So I did this, booted virtually in OSX and boom, completed the install. I ran all windows updates and rebooted and still had no kb or mouse! I assumed that I should get the drivers from Apple so I tried the following in windows (virtually through VMWare):

  • Installing Boot Camp Support Software 5.0.5033
  • Installing an older version of Boot Camp Software.
  • Building a USB drive in OSX and then mounting it in windows

Basically all this does is give me an error saying "Boot Camp x64 is unsupported on this computer model" - and yes I did install a 64bit version of windows. Interestingly when trying to install Boot Camp 3.3 it said "The Boot Camp version currently installed on your system does not require the update.", which is strange as there is no version installed.

I then opened up the directories in the Boot Camp 5.0 zip and tried installing the conveniently named, AppleKeyboardInstaller64.exe and AppleMultiTouchTrackPadInstaller64.exe, but as you may have guessed - did not do anything after rebooting.

I read in various places that you can skip the windows version checking and it will install as I want it too, but had no luck getting this to work. I must say I'm very surprised as my previous experience of Boot Camp (albeit, it was when Windows 7 was new) had never thrown up any problems and now it's taken me almost 48 hours to get to where I am.

Does anyone have any ideas about how I can get this to work without virtually booting in VMWare?

You must log in to answer this question.

Browse other questions tagged .