I have a mid-2009 MacBook Pro 2.53ghz Core 2 Due with 8 Gigs of ram running Mountain Lion.

I am attempting to upgrade the hard drive due to running out of space. I picked up a Seagate Momentus 750gb 7200rpm drive. This is not the hybrid XT drive that seems to cause problems for everybody.

I installed the new drive, put the old one in a USB enclosure and booted from it. I then attempted to use Carbon Copy Cloner to clone to the new internal drive. After cloning a few gigs though, the internal drive would disappear. I finally reinstalled the old drive and put the new one in the enclose and was able to clone that way. I reinstalled the new drive and the computer booted up fine, but would randomly freeze after a few minutes necessitating a hard shut down. I pulled out the new drive, put it in the enclosure and booted from it. The computer ran fine this way and I used it all day via USB with no problems. This lead me to believe the internal SATA cable was faulty as the drive worked fine externally but not internally.

I replaced the SATA cable today and thought the problem was fixed. The computer booted fine and ran for an hour. I used disk utility to verify the drive and repair permissions, but then the computer froze again. I restarted and it ran fine for a few minutes than froze. After each restart the computer will run for a while and then freeze. Any ideas why the drive boots and works fine externally but not internally? The old drive works perfectly fine internally as well. I don't see a problem with the new drive since it works great externally when I boot from it.

  • Hard to say without more info, e.g. crash reports, logs, etc., or without seeing the unit in person. :) If you navigate to /Applications/Utilities/Console.app, are there any logs under "System Diagnostic Reports" that might pertain to your issue? Any entries in "All Messages" or "system.log" from around the timestamp when your issue occurs?
    – thankyour
    Commented Jul 18, 2013 at 20:21
  • Based on the experience of Maciek it looks like some newer drives might need a firmware change (or configuration change) to work reliably inside the Mac. Have you contacted the vendor to see if there are driver options for your drive? Perhaps a legacy operating mode or other setting you can enable to make it look more like a SATA drive from 2009?
    – bmike
    Commented Aug 25, 2013 at 17:24
  • Can you try installing fresh on the new drive? I think the SMC reset suggestion is best, but maybe something's not entirely right with your clone. I use Apple's built-in Disk Utility for cloning, it's never failed me. I've had these sorts of behaviours from drives not getting enough power in the past, not sure that's what's happening for you though. Commented Sep 3, 2014 at 23:05

3 Answers 3


Try resetting both the NV-RAM (P-RAM) but more importantly, the SMC Power Manager for your model, which can be looked up on Apple Support to be certain. It's usually: remove battery, unplug, hold down Power key for 10 seconds.

Also try a Safe Boot. And repairing the hard disk from an external startup, so that Disk Utilities can fully repair. But the problem you describe usually indicates some kind of electrical glitch, which needs to be solved.


Same issue here with seagate momentus 5400 - beachball for exactly 20 seconds every time. Disk activity drops to zero and no entries in console right away ( after some time there are kernel[0]: disk0s2: I/O errors )

It have been serviced - DISK and SATA cable is new ( POWER ON : 549 hrs ) - diagnostic tools shows that everything is allright and SMART utility status: PASSED ( but UDMA CRC Errors are rising - now at 42900 raw value ).

System runs ok on USB drive - but my ST9750423AS still freezes when installed internally.

From these two data points, it seems you can't just put any drive inside the 2009 era Macs and expect them to work with the firmware that's on these newer drives.

  • I/O errors = corrupt filesystem/partitioning scheme, or, the majority of the time, mechanical failure of the drive - regardless of it's SMART status.
    – njboot
    Commented Sep 4, 2014 at 3:54

I owned a Mid-2009 2.53 15" MacBook Pro and upgraded to a Western Digital Scorpio Black 7200 RPM drive. What I discovered was that an EFI/Firmware update (which I had installed prior) that supposedly allowed SATA III drives to work properly was causing issues. I got beach balling and crashing and could not install OS X from scratch onto the drive. WD shipped me a replacement drive, I took the laptop to the Apple Store, nobody could figure it out. But when I downgraded to the previous firmware, the problems went away (although the drive ran theoretically at a lower speed on the SATA bus, it was still an improvement over the stock drive).

I no longer have that firmware downgrade utility, because I've moved on from that machine. You can find information on downgrading here, though: https://discussions.apple.com/thread/4847773?start=0&tstart=0

Warning: attempting to downgrade EFI is not supported by Apple, and theoretically installing Firmware obtained from a 3rd party source can be a security risk. Use at your own peril.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .