When I set my apps to fullscreen with the taskbar still there, it doesn't truly fullscreen the application, it always has that small little border to the left.

I'm using moom as a window resizer, but even without it, I still get the same problem. Is this a setting somewhere? My dock is on the left as well.

enter image description here

same problem here



It is actually 4px on non-retina displays.

I have tried using gdb and strings to find preference keys for removing the gap, but I haven't found anything. Most windows can't be resized so that they cover it with AppleScript either.

The only way I know to remove it is to disable Dock completely with for example launchctl unload /System/Library/LaunchAgents/com.apple.Dock.plist. But it also disables Mission Control, Launchpad, full screen windows, and the application switcher, and it makes desktop backgrounds gray.

A more practical workaround might be to make the desktop background (or parts of it on the side the Dock is on) solid black.

  • 1
    Wow that is incredibly silly. It is infuriating to no end. I am not going to sleep at night. Thank you for looking into it though. – eveo Jul 18 '13 at 1:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .