I am trying to use

defaults write com.apple.Finder AppleShowAllFiles YES

in my terminal but when I do I get the following error:

-bash: defaults: command not found

Any ideas as to what may be causing this issue and how to resolve it?

  • 2
    Try "/usr/bin/defaults write com.apple.Finder AppleShowAllFiles YES" If that works, then you have an issue with your default path in the terminal shell.
    – Kent
    Jul 16, 2013 at 2:23
  • 2
    (I just realized that "default path" in the above comment can be confusing, or a particularly cunning pun, depending on your point of view. It was intended to be neither. A less-confusing statement would be: "If that works, then you have an issue with the path variable that is set in your terminal shell")
    – Kent
    Jul 16, 2013 at 4:20
  • @Kent just take credit for the pun, and be done with it :)
    – MattDMo
    Jul 16, 2013 at 19:05

1 Answer 1


Turns out my .bash_profile got corrupted. I went in via text edit and modified it to revert it to the default settings and all is well again

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .