Want to change the icon of my main drive. I have a bunch of drive icons from interfacelift. They appear to be just .icns packed in the resource fork (%file returns empty, and %cat prints nothing, which is fine, I understand why). My understanding is the way to use these was:

  1. open the icon file info (cmd-i)
  2. select the icon in the upper left, copy it (cmd-c)
  3. select the drive you want to change pull up info (cmd-i)
  4. paste icon on top of icon on drive

Makes sense to me. Doesn't work. Checked from shell, .VolumeIcon.icns doesn't exist on the drive. Any thoughts? I feel dumb, I've done this before, can't make it work now. (10.6.6)

5 Answers 5


For anyone coming to this page for help with changing the icons of applications, it might be helpful to know that a similar solution is needed.

Select the Application you wish to change the icon of, press cmd i, and look at the bottom of the window. Change "everyone" to read/write and then proceed to drag and drop your icon on the applications icon within the info pane. Don't forget to change the permissions back to read only for "everyone" when you're finished.


Did you click on the icon to select it before pasting? I found I needed to do that or it would ignore my paste.

  • 1
    Yup. Was highlighted blue.
    – skarface
    Mar 5, 2011 at 5:31

sigh figured it out. Should have tried this first. I needed to give myself write permissions to the drives. Just added my account as read-write to the drive itself from the info pane. Everything worked after that.

  • Ha! I was just about to ask that. I updated all my icons with new ones but I was unable to update the Time Machine drive icon because of a lack of permissions. Glad you figured it out.
    – sorens
    Mar 5, 2011 at 5:45

Check to make sure you downloaded the correct version. I just went to interfacelift.com, selected an icon set, chose Mac OS X download. The icon set downloaded and unpacked as folder with the icons as folders. I then followed the same steps you listed above and changed the icon of one of my drives.




enter image description here

If you can see the Info window in the 2nd picture (the After), the icon at the top of that window is highlighted with a slight blueish border. That's what it looks like when it is selected.

Hope this helps.


I have found that OSX 10.6 default permissions can cause the problem in third party applications. There is generally not a problem changing Apple icons, because they require your password. To edit the permissions:

  1. Find your application in finder in the Application folder.
  2. Right click -> Get Info, or select the application and press cmd + i.
  3. Edit the application permission by clicking the lock in the bottom right corder, see picture of bottom of the Get Info panel.
  4. Change the permissions for everyone to Read & Write.

enter image description here

Now you can drag the .icns icon image you like over the icon in the top left corner of the Get Info panel.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .