4

I uninstalled zsh pretty soon after I installed it as I realised I had got used to the normal Terminal. The uninstall went successfully and I restarted Terminal, but now it displays my computer-name (tommbp) with a % next to it, as display below:

Wierd Terminal message before cursor

I'm not sure if this impacts on using Terminal but I'm not a Terminal superuser or anything so I'd rather just have it back how it was. Also, I am a front-end dev for a Rails app and when I went to restart the rails server, it says it's not installed and when I try to install it, nothing loads.

Rails not installed

Does anyone know how to fix these two issues?

5

How did you uninstall it? The title bars in the screenshots show that the current command is still zsh, or maybe /bin/zsh.

If you changed this setting in Terminal's preferences, change it back to the default login shell:

If you changed the default login shell, you can change it back to /bin/bash with chsh -s /bin/bash.

  • yeah found this solution literally just before you posted it. Thanks anyway :) Teaches me not to mess with Terminal when I'm not absolutely 100% sure what I'm doing :L – Tom Oakley Jul 12 '13 at 12:35
2

Check your $PROMPT env variable:

echo $PROMPT

Can be set by editing your ~/.profile - there are lots of good tuts out there if you google for them.

  • Thanks Geoff :) echo $PROMPT outputs as %m%# - I've tried to edit .profile but it doesn't work, and I tried editing .bashrc using nano but that didn't work either. Is this normal or am I missing a step? I just put PS1="\h:\W \u\$" (apparently the default for OS X) at the top of .profile and .bashrc. Is this correct? – Tom Oakley Jul 12 '13 at 11:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .