I have spilled a bit of water on the keyboard of my Macbook Pro this Monday. It continued working just fine.

So, I took it home, and 2h later, when I pluged the charger in, the light turned into a very faint/dim green light and it was not charging anymore. It does not consumes battery power, because it's plugged in the outlet, but it does not charge either (says "not charging").

I have tried the following:

  • Plugging it in to a different outlet
  • Trying other MagSafe chargers
  • Making sure it's the correct charger (85w)
  • Resetting SMC
  • Resetting NVRAM

I have opened the back, and although I could not dismount it anymore because the lack of appropriate screwdrivers, I could find no sign of humidity or water damage.

Checking the system information page in the MacOS, I could notice that, when the charger is plugged, amperage information gradually progresses from ~ -2000 to 0.

And it does not seem to recognize the charger. See below:

AC Charger Information:

Connected:     Yes
ID:     0x0000
Wattage (W):     0
Revision:     0x0000
Family:     0x0000
Serial Number:     0x00000000
Charging:     No

Do you guys have any other suggestions?

3 Answers 3


Yes - the SMC reset should resolve any temporary issues with the hardware not sensing the charge adapter. It's even called out in this KB article by Apple as something SMC reset can potentially address:


Once you ruled out SMC needing to be reset, you should get the Mac in to a repair shop or do what they would do to isolate the hardware failure:

  • test your adapter with another computer
  • test your computer with another adapter
  • test your computer with another OS (last resort - SMC and the charging behavior you report can be tested with the OS powered off and only the firmware / SMC regulating the LED color and charge state based on the data it can collect which is faulty in your case)

Once they have isolated the failure (likely to your computer), they would open it and inspect for any corrosion or damage on the logic board and charging circuitry and the either swap and test the magsafe board or the battery or the logic board itself based on experience and the hardware service manual for your model.


That happened to me as well. What I did was I downloaded an app from the Mac App Store called Battery Health. After I run the app my magsafe light was working again and my battery started charging; that seemed to fix the problem for me. I hope it works for you as well


It's probable that your adaptor is wet. The Gold-coated pins actually move toward the inside of the tip of the cable where that green led is. If you can find a way to blow inside that tip while pressing on the pins, tucking them in, you can by one chance dry it and get it working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .