32

Safari unzips .zip and .gz files after downloading. How can I stop this behavior?

45

In the menu bar, go Safari -> Preferences. In the "General" tab, uncheck "Open 'safe' files after downloading". This will stop Safari from automatically unzipping the files.

alt text

  • don't know since when it is the case, but for me and a fresh mojave installation the checkbox did not appear. i first had to activate developer options under Advanced > Show Develop menu in menu bar. Afterwards more options appeared on the general tab. – isaias-b Apr 7 at 12:06
12

Just hold the ⌥ alt button while clicking on the download links.

Tested on OS X Mavericks.

  • Still works fine in Yosemite, and is a useful "I only want to do this occasionally" option. – Matt Gibson Jan 18 '16 at 10:37
2

In Preferences, at the bottom of the General tab, uncheck the "Open "safe" files after downloading" check box.

2

Check out this article if you want to keep the "Safe Downloads" behavior but tweak it a little.

You must log in to answer this question.