0

I have been having trouble booting my macbook pro. I have a backup of everything on the cloud so I tried reinstalling the system from my usb mountain lion stick. Unfortunately the disk utility did not want to reformat my HD and I ended up removing the HD placing it in a hard drive enclosure and proceeding to reformat/reinstall the system. This boots fine from the usb but when I put it internal I get stuck on the boot screen with the apple logo and the spinning lines below.

I tried booting in safe mode and this is the output I got this: enter image description here

Anyone understand that output?

  • Yes...there is a disk I/O error ! Try booting in to disk utility and repairing the disk. Do you pass the disk check? – Ruskes Jul 8 '13 at 20:10
1

Strange indeed!

It runs from USB but not when you put the hard drive back in the computer?

In any case check your disk for problems.

Start up your computer in single-user mode to reach the command line. Note: If necessary, perform a forced restart as described in the Emergency Troubleshooting Handbook that came with your computer.

On desktop computers, you can do this by pressing the reset/interrupt button (if there is one) or holding down the power button for several seconds. On portable computers, simultaneously press the Command-Control-power keys. If your portable computer doesn't restart with this method, you may need to reset the Power Manager. At the command-line prompt type:

/sbin/fsck -fy

Press Return. fsck will go through five "phases" and then return information about your disk's use and fragmentation. Once it finishes,

it'll display this message if no issue is found:

    ** The volume (name_of_volume) appears to be OK 

If fsck found issues and has altered, repaired, or fixed anything, it will display this message:

    ***** FILE SYSTEM WAS MODIFIED ***** 

Important: If this message appears, repeat the fsck command you typed in step 2 until fsck tells you that your volume appears to be OK

(first-pass repairs may uncover additional issues, so this is a normal thing to do).

When fsck reports that your volume is OK, type reboot at the prompt and then press Return.

But it could be just the flat cable connecting the hard drive to motherboard !

  • Thanks Buscar! I checked everything for problems and the repair failed but when I tried the fsck it said the volume appears to be OK. I actually just put a new hard drive in and began installing mac osx but when the time came for it to restart it refused to get past the boot screen. Does this indicate it may be a motherboard issue? – Graeme Jul 9 '13 at 0:58
  • I would say so :(, but again, you said it works when you use external hard drive true usb ? Did you reset the SMC ? – Ruskes Jul 9 '13 at 1:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .