1

I'm having a heck of a time trying to disable the option "Check for updates Automatically"

I ran composer to see what plist was being modified and it looks like ~/Library/Preferences/com.oracle.javadeployment.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"    "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>/com/oracle/javadeployment/</key>
    <dict>
        <key>deployment.macosx.check.update</key>
        <string>false</string>
</dict>
</dict>
</plist>

So I experimented with changing that value to true or false and it would not effect the checkbox under the Java Control Panel > Update > Check for Updates Automatically

Your assistance would be much appreciated.

Initially I was looking @ /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

  • 1
    What is the underlying problem you are trying to solve? – Thorbjørn Ravn Andersen Jul 8 '13 at 18:45
  • Do you mean to say that you can not disable it in Java Control Panel ? or are you trying to have some kind of script do that? – Ruskes Jul 8 '13 at 18:53
  • 1
    I am trying to disable Java from prompting my users to update. I found a script posted here, which turns off the auto update feature: jamfnation.jamfsoftware.com/discussion.html?id=6489 – Paul Mung Jul 8 '13 at 22:05
  • @ThorbjørnRavnAndersen I'm trying to deploy these settings to a group of users... looks like running the script above is the best method. – Paul Mung Jul 8 '13 at 22:08
  • @PaulMung if this ends up working for you please help make SO stronger by posting your own solution as an answer. – AllInOne Jul 8 '13 at 23:07
6

Open a Terminal and execute:

sudo defaults write /Library/Preferences/com.oracle.java.Java-Updater JavaAutoUpdateEnabled -bool false

Source: https://jamfnation.jamfsoftware.com/discussion.html?id=6489

Update: This answer has been confirmed to work on OS X 10.11.5 (El Capitan)

  • 1
    Next time put the answer like you would expect from others, don't just link the article where you have sift through another huge thread. The solution is do a "sudo defaults write /Library/Preferences/com.oracle.java.Java-Updater JavaAutoUpdateEnabled -bool false" in Terminal. – OpenUserX03 Oct 21 '14 at 6:13
0

Perhaps a more general approach would be to unload com.oracle.java.Java-Updater.plist via "sudo launchctl unload com.oracle.java.Java-Updater.plist" , and remove the plist from /Library/LaunchAgents?

  • 1
    Is this answer (which you know to solve the problem), a guess or a follow-up question? – nohillside Oct 7 '15 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .