Having trouble with updating my Instagram app.

When it was time for the update, I clicked "update app" of course, but it said the app couldn't be updated. Now I can't access it. Since then, it just says "Waiting…" and I can't do anything with it.

  • I tried to delete it but the × doesn't appear in the top corner to allow me to delete it.
  • When I click the app to see if it'll load, nothing happens.
  • I even hooked it up to iTunes to see if I could delete it there but the × still doesn't show.
  • I went to my settings to manage my storage and I clicked "delete app" which removed it from the list, yet it's still on my iPod.

I don't get it. I really don't want to have to restore my iPod just to fix a problem with one app. I can update, download and delete other apps just fine.

  • what OS are you using? Commented Mar 18, 2014 at 23:15

3 Answers 3


Make sure you are connected to WiFi, then restart your device.

If you're desperate to just use the App, you can still access it by double-tapping the home button and entering the App via the multi-tasking menu.

  • I'm always connected to wifi. I have wifi at home so it's always connected. I always restart my iPod & it never works. I do want to use the app or at least be able to delete it. & It doesn't show up in my multitask menu. I've tried everything..
    – Briana R.
    Commented Jul 10, 2013 at 11:08
  • Are you actually doing a hard reset? or just turning the phone off and on? Hold lock button and home button together to hard reset. Commented Jul 10, 2013 at 17:49
  • I've done both actions plenty of times. I actually just finished doing a hard reset & nothing's changed. Maybe if I continuously hard reset it, back to back, it might work? I don't know.. I think it's worth a shot at this point. I'll try it.
    – Briana R.
    Commented Jul 10, 2013 at 23:54
  • & of course, that didn't work.. Grr.
    – Briana R.
    Commented Jul 11, 2013 at 7:58
  • have you tried signing out of the store on your phone? Commented Jul 11, 2013 at 19:01

That recently happened to me but the way I fixed it. I went on Settings> General> Usage>
[The app you want] then delete app. Then go onto the home screen and the app should be just a blank white icon with lines going across it. Hold onto it and you should be able to delete it by tapping onto the 'x' button. There you have it! You could reinstall it to use it again. Hope that helped

  • I've tried all solutions above and below, only yours worked for me, thanks a lot! A great up vote for you!
    – acoustic
    Commented Jun 15, 2016 at 2:00

The problem isn't with the app, but with the part of the OS that controls the app placement (springboard) and interaction between the touch and app launching.

The sure way to recover is to wipe the device and restore from a backup (or set it up new), but I understand the hesitance to go through that in many cases.

This answer has links to quite a few threads on how to overcome this, but since it's not clear what you've tried, perhaps editing your post will help us pinpoint your specific case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .