1

I've got a MacBook Pro (17", 2010 model), and recently I've been having a few issues with the keyboard. Frequently, some keys on the keyboard fail to respond. These are mainly on the right-hand side of the keyboard (P, O, ;, return, F11, plus others). An external keyboard does not have any issues.

At first I thought it may be a hardware issue, but (a) there seems to be no issue when I boot into Windows 7 (Bootcamp), and (b) I can temporarily fix the problem by pressing F12 (Volume Up).

Does anybody have any ideas of what to try? I could reinstall OSX, but that seems drastic at this stage. It's still under warranty, but since I need the machine for work, I don't really want to send it in for repair until I've tried everything else.

Thanks in advance.

2

I would try a Genius Bar at a local mac store if you are located near one. I have seen them fix some weird s/w issues right there.

  • I'm about 30mins drive from the nearest one. – Darren Oster Mar 5 '11 at 3:44
1

That remind me of a problem MacBook had a few years back. But that was solved through a software update. Are you updated to the latest version?

Also, can you tell us any (background) app that is running on your computer?

  • 1
    There are a few, Alfred, Dropbox, NowPlaying, Live Mesh, GMail Notifier. I guess I'll try disabling one at a time to see if anything works there. – Darren Oster Mar 5 '11 at 3:46
  • 2
    I would start with Live Mesh first to see if that is doing it. Dropbox and GMail Notifier are widely used and unlikely to have caused it. – john busteed Mar 7 '11 at 14:48
1

I had these problem for 9 months now, some keys won't work, TAB, space, Down Arrow... while external keyboards always work, both USB and Bluetooth.

So I presed F12 key and the problem solved I Don't know if will last long, but the fix happened instantly after F12.

1

Ended up taking it in to the Genius Bar. They suggest reinstalling Mac OSX, which I did, but the problem was back within half an hour. Took it back and they replaced the Logic board and the Top Cover (including the keyboard). Not sure which it was, but the problem's gone now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .